Matrix - HDU 2686 dp

Matrix

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1548    Accepted Submission(s): 834


Problem Description
Yifenfei very like play a number game in the n*n Matrix. A positive integer number is put in each area of the Matrix.
Every time yifenfei should to do is that choose a detour which frome the top left point to the bottom right point and than back to the top left point with the maximal values of sum integers that area of Matrix yifenfei choose. But from the top to the bottom can only choose right and down, from the bottom to the top can only choose left and up. And yifenfei can not pass the same area of the Matrix except the start and end. 
 

Input
The input contains multiple test cases.
Each case first line given the integer n (2<n<30) 
Than n lines,each line include n positive integers.(<100)
 

Output
For each test case output the maximal values yifenfei can get.
 

Sample Input
  
  
2 10 3 5 10 3 10 3 3 2 5 3 6 7 10 5 1 2 3 4 5 2 3 4 5 6 3 4 5 6 7 4 5 6 7 8 5 6 7 8 9
 

Sample Output
  
  
28 46 80

题意:从左上角到右下角再返回左上角,不能走到重复的格子,问你最大的路径的权值和是多少。

思路:先循环要走多少步,每步都对应有右边走的点和下边走的点可能落在哪些地方,对于这些情况,考虑他的上一步可以走到这种情况的情况,然后dp。

AC代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int dp[35][35][35][35],value[35][35];
int main()
{ int n,i,j,k,x1,x2,y1,y2;
  while(~scanf("%d",&n))
  { for(i=1;i<=n;i++)
     for(j=1;j<=n;j++)
      scanf("%d",&value[i][j]);
    memset(dp,0,sizeof(dp));
    for(k=1;k<=2*n-3;k++)
     for(x1=2;x1<=1+k && x1<=n;x1++)
     { y1=2+k-x1;
       for(y2=2;y2<=1+k && y2<=n;y2++)
       { x2=2+k-y2;
         if(x1>x2 && y2>y1)
         { dp[y1][x1][y2][x2]=max(dp[y1][x1-1][y2][x2-1],dp[y1-1][x1][y2-1][x2]);
           dp[y1][x1][y2][x2]=max(dp[y1][x1][y2][x2],dp[y1-1][x1][y2][x2-1]);
           if(!(x1-x2==1 && y2-y1==1))
            dp[y1][x1][y2][x2]=max(dp[y1][x1][y2][x2],dp[y1][x1-1][y2-1][x2]);
           dp[y1][x1][y2][x2]+=value[y1][x1]+value[y2][x2];
         }
       }
     }
    printf("%d\n",dp[n-1][n][n][n-1]+value[1][1]+value[n][n]);
  }
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值