Rating - HDU 4870 期望dp

Rating

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 403    Accepted Submission(s): 254
Special Judge


Problem Description
A little girl loves programming competition very much. Recently, she has found a new kind of programming competition named "TopTopTopCoder". Every user who has registered in "TopTopTopCoder" system will have a rating, and the initial value of rating equals to zero. After the user participates in the contest held by "TopTopTopCoder", her/his rating will be updated depending on her/his rank. Supposing that her/his current rating is X, if her/his rank is between on 1-200 after contest, her/his rating will be min(X+50,1000). Her/His rating will be max(X-100,0) otherwise. To reach 1000 points as soon as possible, this little girl registered two accounts. She uses the account with less rating in each contest. The possibility of her rank between on 1 - 200 is P for every contest. Can you tell her how many contests she needs to participate in to make one of her account ratings reach 1000 points?
 

Input
There are several test cases. Each test case is a single line containing a float number P (0.3 <= P <= 1.0). The meaning of P is described above.
 

Output
You should output a float number for each test case, indicating the expected count of contest she needs to participate in. This problem is special judged. The relative error less than 1e-5 will be accepted.
 

Sample Input
  
  
1.000000 0.814700
 

Sample Output
  
  
39.000000 82.181160
 

题意:一个人有两个账号,每次用积分少的号比赛,有p的概率加50分,还有1-p的概率减100分,最低减到0,问有一个号到1000分的期望是多少。

思路:dp[i]表示从i分增加到i+1分的期望。dp[i]=p+(1-p)*(dp[i-2]+dp[i-1]+dp[i]+1)。整理后dp[i]=1/p+(1-p)/p*(dp[i-2]+dp[i-1]); dp[0]=1/p,dp[1]=1/p/p。然后就可以推出结果了。

AC代码如下:

#include<cstdio>
#include<cstring>
using namespace std;
double dp[30],ans[30][30],p;
int main()
{ int i,j,k;
  while(~scanf("%lf",&p))
  { dp[0]=1/p;
    dp[1]=1/p/p;
    for(i=2;i<=19;i++)
     dp[i]=1/p+(1-p)/p*(dp[i-2]+dp[i-1]);
    for(i=0;i<=20;i++)
    { ans[i+1][i]=ans[i][i]+dp[i];
      ans[i+1][i+1]=ans[i+1][i]+dp[i];
    }
    printf("%.6f\n",ans[20][19]);
  }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值