How to Type - HDU 2588 dp

How to Type

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3496    Accepted Submission(s): 1623


Problem Description
Pirates have finished developing the typing software. He called Cathy to test his typing software. She is good at thinking. After testing for several days, she finds that if she types a string by some ways, she will type the key at least. But she has a bad habit that if the caps lock is on, she must turn off it, after she finishes typing. Now she wants to know the smallest times of typing the key to finish typing a string.
 

Input
The first line is an integer t (t<=100), which is the number of test case in the input file. For each test case, there is only one string which consists of lowercase letter and upper case letter. The length of the string is at most 100.
 

Output
For each test case, you must output the smallest times of typing the key to finish typing this string.
 

Sample Input
  
  
3 Pirates HDUacm HDUACM
 

Sample Output
  
  
8 8 8
Hint
The string “Pirates”, can type this way, Shift, p, i, r, a, t, e, s, the answer is 8. The string “HDUacm”, can type this way, Caps lock, h, d, u, Caps lock, a, c, m, the answer is 8 The string "HDUACM", can type this way Caps lock h, d, u, a, c, m, Caps lock, the answer is 8
 

题意:用shift和Caps Lock打出含有大小写的字符串,问最少需要敲多少次键盘。注意最后要关闭Caps Lock。

思路:dp[i][0]表示打完第i个字符后Caps Lock为关的最少次数,dp[i][1]表示打完第i个字符后Caps Lock为开的最少次数,转移方程看代码吧。

AC代码如下:

#include<cstring>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<string>
using namespace std;
int dp[110][2];
char s[110];
int main()
{ int t,i,j,k,len,ans=0;
  scanf("%d",&t);
  while(t--)
  { scanf("%s",s+1);
    len=strlen(s+1);
    dp[0][0]=0;dp[0][1]=1;
    for(i=1;i<=len;i++)
    { if(islower(s[i]))
      { dp[i][0]=min(dp[i-1][0]+1,dp[i-1][1]+2);
        dp[i][1]=min(dp[i-1][1]+2,dp[i-1][0]+2);
      }
      else
      { dp[i][0]=min(dp[i-1][0]+2,dp[i-1][1]+2);
        dp[i][1]=min(dp[i-1][0]+2,dp[i-1][1]+1);
      }
    }
    printf("%d\n",min(dp[len][0],dp[len][1]+1));
  }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值