Robotruck - ZOJ 3031 dp

Robotruck

Time Limit: 5 Seconds       Memory Limit: 32768 KB

This problem is about a robotic truck that distributes mail packages to several locations in a factory. The robot sits at the end of a conveyer at the mail office and waits for packages to be loaded into its cargo area. The robot has a maximum load capacity, which means that it may have to perform several round trips to complete its task. Provided that the maximum capacity is not exceeded, the robot can stop the conveyer at any time and start a round trip distributing the already collected packages. The packages must be delivered in the incoming order.

The distance of a round trip is computed in a grid by measuring the number of robot moves from the mail office, at location (0,0), to the location of delivery of the first package, the number of moves between package delivery locations, until the last package, and then the number of moves from the last location back to the mail office. The robot moves a cell at a time either horizontally or vertically in the factory plant grid. For example, consider four packages, to be delivered at the locations (1,2),(1,0), (3,1), and (3,1). By dividing these packages into two round trips of two packages each, the number of moves in the first trip is 3+2+1=6, and 4+0+4=8 in the second trip. Notice that the two last packages are delivered at the same location and thus the number of moves between them is 0.

Given a sequence of packages, compute the minimum distance the robot must travel to deliver all packages.

Input

A positive integer P in a single line followed by a sequence of P test cases. Each test case consists of a line containing one positive integer C, not greater than 1,000,000, indicating the maximum capacity of the robot, a line containing one positive integer N, not greater than 100,000, which is the number of packages to be loaded from the conveyer. Next, there are N lines containing, for each package, two non-negative integers to indicate its delivery location in the grid, and a non-negative integer to indicate its weight. The weight of the packages is always smaller than the robot's maximum load capacity. The order of the input is the order of appearance in the conveyer.

Output

One line containing one integer representing the minimum number of moves the robot must travel to deliver all the packages.

Sample Input

1
10
4
1 2 3
1 0 3
3 1 4
3 1 4

Sample Output

14

题意:一个机器人在一个二维的平面运东西,每次能同时拿走的物品重量不能超过他的承受力,需要按照顺序去运送物品,每个单位时间走一个单位长度,为运送物品的最少时间是多少。

思路:简单的dp,dp[i]表示运送前i个物品的最短时间,dp[j]=min(dp[j],dp[i-1]+dis[j]-dis[i]+x[i]+y[i]+x[j]+y[j]);

AC代码如下:

#include<cstdio>
#include<cstring>
#include<cstdlib>
using namespace std;
typedef long long ll;
ll dp[100010],INF=1e18,ret,x[100010],y[100010],dis[100010];
int weight[100010];
int main()
{
    int t,n,m,i,j,k;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&m,&n);
        for(i=1;i<=n;i++)
        {
            scanf("%lld%lld%d",&x[i],&y[i],&weight[i]);
            weight[i]+=weight[i-1];
            dis[i]=dis[i-1]+abs(x[i]-x[i-1])+abs(y[i]-y[i-1]);
            dp[i]=INF;
        }
        for(j=1;j<=n;j++)
           for(i=j;i>=1;i--)
           {
               if(weight[j]-weight[i-1]>m)
                 break;
               ret=dp[i-1]+dis[j]-dis[i]+x[i]+y[i]+x[j]+y[j];
               if(ret<dp[j])
                 dp[j]=ret;
           }
        printf("%lld\n",dp[n]);
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值