Time Limit: 2000MS | Memory Limit: 65536K | |
Total Submissions: 31588 | Accepted: 11495 |
Description
While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.
As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .
To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.
Input
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2.. M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2.. M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.
Output
Sample Input
2 3 3 1 1 2 2 1 3 4 2 3 1 3 1 3 3 2 1 1 2 3 2 3 4 3 1 8
Sample Output
NO YES
Hint
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.
题意:给你一个人从u到v的距离,还有有向的u到v时间倒流,问一个人能否在回到起始点的时候回到过去。
思路:spfa,当一个点重复n次以上的时候证明有负环。
AC代码如下:
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
struct node
{
int y,w,next;
}e[8010];
int n,m,p,h[510],d[510],tot,ret[510];
bool vis[510];
queue<int> qu;
void ins(int x,int y,int w)
{
e[++tot].y=y;
e[tot].w=w;
e[tot].next=h[x];
h[x]=tot;
}
bool spfa(int s)
{
int i,j,k,x,y;
qu.push(s);
memset(vis,0,sizeof(vis));
for(i=1;i<=n;i++)
d[i]=1000000000;
d[s]=0;
vis[s]=1;
while(!qu.empty())
{
x=qu.front();
qu.pop();
for(i=h[x];i;i=e[i].next)
{
y=e[i].y;
if(d[x]+e[i].w<d[y])
{
d[y]=d[x]+e[i].w;
if(!vis[y])
{
vis[y]=1;
qu.push(y);
if(++ret[y]>=n)
return true;
}
}
}
vis[x]=0;
}
return false;
}
int main()
{
int T,t,i,j,k,u,v;
bool flag;
scanf("%d",&T);
for(t=1;t<=T;t++)
{
scanf("%d%d%d",&n,&m,&p);
memset(h,0,sizeof(h));
memset(ret,0,sizeof(ret));
tot=0;
for(i=1;i<=m;i++)
{
scanf("%d%d%d",&u,&v,&k);
ins(v,u,k);
ins(u,v,k);
}
for(i=1;i<=p;i++)
{
scanf("%d%d%d",&u,&v,&k);
ins(u,v,-k);
}
flag=spfa(1);
if(flag)
printf("YES\n");
else
printf("NO\n");
}
}