Swap - HDU 2819 二分图匹配

76 篇文章 0 订阅

Swap

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1538    Accepted Submission(s): 530
Special Judge


Problem Description
Given an N*N matrix with each entry equal to 0 or 1. You can swap any two rows or any two columns. Can you find a way to make all the diagonal entries equal to 1?
 

Input
There are several test cases in the input. The first line of each test case is an integer N (1 <= N <= 100). Then N lines follow, each contains N numbers (0 or 1), separating by space, indicating the N*N matrix.
 

Output
For each test case, the first line contain the number of swaps M. Then M lines follow, whose format is “R a b” or “C a b”, indicating swapping the row a and row b, or swapping the column a and column b. (1 <= a, b <= N). Any correct answer will be accepted, but M should be more than 1000.

If it is impossible to make all the diagonal entries equal to 1, output only one one containing “-1”. 
 

Sample Input
  
  
2 0 1 1 0 2 1 0 1 0
 

Sample Output
  
  
1 R 1 2 -1
 

题意:是否存在一种方式使得交换行和列后num[i][i]=1。如果存在的话输出交换方式。

思路:构建二分图行和列匹配,如果不能完全匹配,那么就输出-1。可以的话,根据match[i]匹配的结果,就是答案的列应该怎么排列的结果,最后一定是存在只交换列(或者行)就可以满足题意的方式。

AC代码如下:

#include<cstdio>
#include<cstring>
using namespace std;
int n,m,G[110][110],match[110],vis[110],VIS,f[110],ans[110][2];
bool dfs(int u)
{
    int i;
    for(i=1;i<=n;i++)
       if(G[i][u] && vis[i]!=VIS)
       {
           vis[i]=VIS;
           if(match[i]==0 || dfs(match[i]))
           {
               match[i]=u;
               return true;
           }
       }
    return false;
}
int main()
{
    int i,j,k,ret;
    while(~scanf("%d",&n))
    {
        for(i=1;i<=n;i++)
           for(j=1;j<=n;j++)
              scanf("%d",&G[i][j]);
        memset(match,0,sizeof(match));
        ret=0;
        for(i=1;i<=n;i++)
        {
            VIS++;
            if(dfs(i))
              ret++;
        }
        if(ret<n)
        {
            printf("-1\n");
            continue;
        }
        m=0;
        for(i=1;i<=n;i++)
           f[i]=i;
        for(i=1;i<=n;i++)
        {
            if(match[i]!=f[i])
            {
                for(j=i+1;j<=n;j++)
                   if(match[i]==f[j])
                     break;
                m++;
                ans[m][0]=i;
                ans[m][1]=j;
                f[j]=f[i];
            }
        }
        printf("%d\n",m);
        for(i=1;i<=m;i++)
           printf("C %d %d\n",ans[i][0],ans[i][1]);
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值