The Tourist Guide - UVa 10099 Floyd

76 篇文章 0 订阅

Problem D

The Tourist Guide

Input: standard input

Output: standard output

 

Mr. G. works as a tourist guide. His current assignment is to take some tourists from one city to another. Some two-way roads connect the cities. For each pair of neighboring cities there is a bus service that runs only between those two cities and uses the road that directly connects them. Each bus service has a limit on the maximum number of passengers it can carry. Mr. G. has a map showing the cities and the roads connecting them. He also has the information regarding each bus service. He understands that it may not always be possible for him to take all the tourists to the destination city in a single trip. For example, consider the following road map of 7 cities. The edges connecting the cities represent the roads and the number written on each edge indicates the passenger limit of the bus service that runs on that road.

 

                           

Now, if he wants to take 99 tourists from city 1 to city 7, he will require at least 5 trips, since he has to ride the bus with each group, and the route he should take is : 1 - 2 - 4 - 7.

But, Mr. G. finds it difficult to find the best route all by himself so that he may be able to take all the tourists to the destination city in minimum number of trips. So, he seeks your help.

 

Input

The input will contain one or more test cases. The first line of each test case will contain two integers: N (N<= 100) and R representing respectively the number of cities and the number of road segments. Then R lines will follow each containing three integers: C1C2 andPC1 and C2 are the city numbers and P (P> 1) is the limit on the maximum number of passengers to be carried by the bus service between the two cities. City numbers are positive integers ranging from 1 to N. The (R + 1)-th line will contain three integers: SD and Trepresenting respectively the starting city, the destination city and the number of tourists to be guided.

The input will end with two zeroes for N and R.

 

Output

For each test case in the input first output the scenario number. Then output the minimum number of trips required for this case on a separate line. Print a blank line after the output of each test case.

 

Sample Input

7 10
1 2 30
1 3 15
1 4 10
2 4 25
2 5 60
3 4 40
3 6 20
4 7 35
5 7 20
6 7 30
1 7 99
0 0

Sample Output

Scenario #1
Minimum Number of Trips = 5


题意:给你一些点和边,求从u到v的每条路径中的最小值的最大值是多少。最后算需要走多少趟,注意:导游也算人数Σ( ° △ °|||)︴这一点我看样例看了好久才想到。。。【我脑残

思路:Floyd最短路径的算法,简单粗暴优雅~~~

AC代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int n,m,dis[110][110];
int main()
{
    int t=0,i,j,k,u,v,d,ans,p;
    while(~scanf("%d%d",&n,&m) && n+m>0)
    {
        memset(dis,0,sizeof(dis));
        for(i=1;i<=m;i++)
        {
            scanf("%d%d%d",&u,&v,&d);
            dis[u][v]=dis[v][u]=d;
        }
        for(k=1;k<=n;k++)
           for(i=1;i<=n;i++)
              for(j=1;j<=n;j++)
                 dis[i][j]=max(dis[i][j],min(dis[i][k],dis[k][j]));
        scanf("%d%d%d",&u,&v,&d);
        p=dis[u][v]-1;
        ans=(d+p-1)/p;
        printf("Scenario #%d\nMinimum Number of Trips = %d\n\n",++t,ans);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值