Closest Sums - UVa10487 二分

Closest Sums
Input: standard input
Output: standard output
Time Limit: 3 seconds

 

Given is a set of integers and then a sequence of queries. A query gives you a number and asks to find a sum of two distinct numbers from the set, which is closest to the query number.

Input

Input contains multiple cases.

Each case starts with an integer n (1<n<=1000), which indicates, how many numbers are in the set of integer. Next n lines contain n numbers. Of course there is only one number in a single line. The next line contains a positive integer m giving the number of queries, 0 < m < 25. The next m lines contain an integer of the query, one per line.

Input is terminated by a case whose n=0. Surely, this case needs no processing.

Output

Output should be organized as in the sample below. For each query output one line giving the query value and the closest sum in the format as in the sample. Inputs will be such that no ties will occur.

Sample input

5

3
12
17
33
34
3
1
51
30
3
1
2
3
3
1
2
3

3

1
2
3
3
4
5
6
0

Sample output

Case 1:
Closest sum to 1 is 15.
Closest sum to 51 is 51.
Closest sum to 30 is 29.
Case 2:
Closest sum to 1 is 3.
Closest sum to 2 is 3.
Closest sum to 3 is 3.
Case 3:
Closest sum to 4 is 4.
Closest sum to 5 is 5.
Closest sum to 6 is 5.

题意:给你n个数,有m次查询,每次给你一个数k,求上面n个数其中两个数的和最接近k的是多少。

思路:先求出两个数的所有可能的和,排序后二分找到小于等于k的,和大于等于k的,然后找其中一个最接近k的作为答案。

AC代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cstdlib>
using namespace std;
int t,n,m,num[1010],sum[1000010],tot;
int find1(int ret)
{
    int l=1,r=tot,mi;
    while(l<r)
    {
        mi=(l+r+1)/2;
        if(sum[mi]<=ret)
          l=mi;
        else
          r=mi-1;
    }
    return l;
}
int find2(int ret)
{
    int l=1,r=tot,mi;
    while(l<r)
    {
        mi=(l+r)/2;
        if(sum[mi]>=ret)
          r=mi;
        else
          l=mi+1;
    }
    return l;
}
int main()
{
    int i,j,k,num1,num2;
    while(~scanf("%d",&n) && n>0)
    {
        for(i=1;i<=n;i++)
           scanf("%d",&num[i]);
        tot=0;
        for(i=1;i<=n;i++)
           for(j=i+1;j<=n;j++)
              if(num[i]!=num[j])
              sum[++tot]=num[i]+num[j];
        sort(sum+1,sum+1+tot);
        scanf("%d",&m);
        printf("Case %d:\n",++t);
        for(i=1;i<=m;i++)
        {
            scanf("%d",&k);
            num1=sum[find1(k)];
            num2=sum[find2(k)];
            if(abs(num1-k)>abs(num2-k))
              num1=num2;
            printf("Closest sum to %d is %d.\n",k,num1);
        }
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值