A Multiplication Game - HDU 1517 博弈

29 篇文章 0 订阅

A Multiplication Game

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4259    Accepted Submission(s): 2435


Problem Description
Stan and Ollie play the game of multiplication by multiplying an integer p by one of the numbers 2 to 9. Stan always starts with p = 1, does his multiplication, then Ollie multiplies the number, then Stan and so on. Before a game starts, they draw an integer 1 < n < 4294967295 and the winner is who first reaches p >= n.
 

Input
Each line of input contains one integer number n.
 

Output
For each line of input output one line either 

Stan wins. 

or 

Ollie wins.

assuming that both of them play perfectly.
 

Sample Input
  
  
162 17 34012226
 

Sample Output
  
  
Stan wins. Ollie wins. Stan wins.
 

题意:有一个数字,开始为1,每个人可以把它乘以2-9,谁先得到大于等于n的数字,谁就获胜,问先手胜负。

思路:我们可以得到2-9先手必胜,10-18先手必败,19-18*9先手必胜,以此类推。

AC代码如下:

#include<cstdio>
#include<cstring>
using namespace std;
typedef long long ll;
struct node
{
    ll a,b;
    bool type;
}arr[110];
ll n;
int main()
{
    int i,j,k=0;
    arr[0].a=arr[0].b=1;
    while(true)
    {
        k++;
        if(k&1)
        {
            arr[k].a=arr[k-1].b+1;
            arr[k].b=arr[k-1].b*9;
        }
        else
        {
            arr[k].a=arr[k-1].b+1;
            arr[k].b=arr[k-1].b*2;
        }
        if(arr[k].b>4294967295LL)
          break;
    }
    while(~scanf("%I64d",&n))
    {
        for(i=1;i<=15;i++)
           if(arr[i].a<=n && n<=arr[i].b)
              break;

        if(i&1)
          printf("Stan wins.\n");
        else
          printf("Ollie wins.\n");
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值