Climbing the Hill - HDU 4315 阶梯博弈变形

29 篇文章 0 订阅

Climbing the Hill

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 996    Accepted Submission(s): 442


Problem Description
Alice and Bob are playing a game called "Climbing the Hill". The game board consists of cells arranged vertically, as the figure below, while the top cell indicates the top of hill. There are several persons at different cells, and there is one special people, that is, the king. Two persons can't occupy the same cell, except the hilltop.

At one move, the player can choose any person, who is not at the hilltop, to climb up any number of cells. But the person can't jump over another one which is 
above him. Alice and Bob move the persons alternatively, and the player who move the king to the hilltop will win. 



Alice always move first. Assume they play optimally. Who will win the game?
 

Input
There are several test cases. The first line of each test case contains two integers N and k (1 <= N <= 1000, 1 <= k <= N), indicating that there are N persons on the
hill, and the king is the k-th nearest to the top. N different positive integers followed in the second line, indicating the positions of all persons. (The hilltop is No.0 cell, the cell below is No.1, and so on.) These N integers are ordered increasingly, more than 0 and less than 100000.
 

Output
If Alice can win, output "Alice". If not, output "Bob".
 

Sample Input
  
  
3 3 1 2 4 2 1 100 200
 

Sample Output
  
  
Bob Alice
Hint
The figure illustrates the first test case. The gray cell indicates the hilltop. The circles indicate the persons, while the red one indicates the king. The first player Alice can move the person on cell 1 or cell 4 one step up, but it is not allowed to move the person on cell 2.
 


参考:http://blog.csdn.net/longshuai0821/article/details/7794323

AC代码如下:

#include<cstdio>
#include<cstring>
using namespace std;
int n,num[1010];
int main()
{
    int i,j,k,S;
    while(~scanf("%d%d",&n,&k))
    {
        for(i=1;i<=n;i++)
           scanf("%d",&num[i]);
        if(k==1)
        {
            printf("Alice\n");
            continue;
        }
        if(n%2==0)
        {
            S=0;
            for(i=n;i>0;i-=2)
               S^=num[i]-num[i-1]-1;
            if(S==0)
              printf("Bob\n");
            else
              printf("Alice\n");
        }
        if(n&1)
        {
            S=num[1];
            if(k==2)
              S--;
            for(i=n;i>1;i-=2)
               S^=num[i]-num[i-1]-1;
            if(S==0)
              printf("Bob\n");
            else
              printf("Alice\n");
        }
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值