POJ 1856 Sea Battle(dfs)

Description

During the Summit, the armed forces will be highly active. The police will monitor Prague streets, the army will guard buildings, the Czech air space will be full of American F-16s. Moreover, the ships and battle cruisers will be sent to guard the banks of the Vltava river. Unfortunately, in the case of any incident, the Czech Admiralty have only a few captains able to control over the large sea battle. Therefore, it was decided to educate new admirals. As an excellent preparation, the game of "Sea Battle" was chosen to help with their study program. 

In this well-known game, a predefined number of ships of predefined shapes are placed on the square board in such a way that they cannot contact one another even with their corners. In this task, we will consider rectangular shaped ships only. The unknown number of rectangular ships of unknown sizes are placed on a rectangular board. All the ships are full rectangles built of hash characters. Write a program that counts the total number of ships present in the field. 

Input

The input consists of more scenarios. The description of each scenario begins with two integer numbers R and C separated with a single space, 1 <= R,C <= 1000. These numbers give the number of rows and columns in the game field. 

After these two numbers, there are R lines, each of them containing C characters. Each character is either hash ("#") or dot ("."). Hashes denote ships, dots water. 

Then, the next scenario description begins. At the end of the input, there will be a line containing two zeros instead of the field size. 

Output

Output a single line for every scenario. If the ships were placed correctly (i.e., there are only rectangles that do not touch each other even with a corner), print the sentence "There are S ships." where S is the number of ships. 

Otherwise, print the sentence "Bad placement.". 

Sample Input

6 6
.....#
##...#
##...#
..#..#
.....#
######
6 8
.....#.#
##.....#
##.....#
.......#
#......#
#..#...#
0 0

Sample Output

Bad placement.
There are 5 ships.

Source


                                                                                                                                                                             #

题意:就是#必须是矩阵,即为长方形或正方形,还有每个#矩形的角不能共着,如第一个图中的##  因为他们有一个点共着了,而题目问的是只要有供着的,就输出

Bad placement.

   

否则输出矩形个数


比赛时没有好的思路,纠结好久,后来看别人代码,碉堡了,每次看到#,就dfs,记录搜到的最大x,y,最小x,y,和#的个数  temp  ,if(temp==(maxx-minx+1)*(maxy-miny+1)),那么就是满足条件的,否者不满足输出

Bad placement.


不说了,上代码了


#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define N 1005

char a[N][N];

int n,m;
int minx,maxx,miny,maxy;

int temp;

void dfs(int x,int y)
{
    a[x][y]='.';
    temp++;

    int i,j;
    minx=min(minx,x);
    maxx=max(maxx,x);

    miny=min(miny,y);
    maxy=max(maxy,y);

    for(i=-1;i<=1;i++)
        for(j=-1;j<=1;j++)
    {
        int xx=x+i;
        int yy=y+j;
        if(xx>=0&&xx<n&&yy>=0&&yy<m&&a[xx][yy]=='#')
            dfs(xx,yy);
    }
}
int main()
{
    int i,j;
    while(scanf("%d%d",&n,&m),n+m)
    {
        for(i=0;i<n;i++)
            scanf("%s",a[i]);

        int ans=0,flag=0;

        for(i=0;i<n;i++)
            for(j=0;j<m;j++)
            if(a[i][j]=='#')
            {
                minx=maxx=i;
                miny=maxy=j;
                temp=0;
                dfs(i,j);

                if(temp==(maxx-minx+1)*(maxy-miny+1))
                   ans++;
                   else
                {
                    flag=1;
                    i=n;
                    j=m;
                }
            }

            if(flag)
                printf("Bad placement.\n");
            else
                printf("There are %d ships.\n",ans);
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值