poj 3268 (最短路 spfa)

Language:
Silver Cow Party
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 12910 Accepted: 5776

Description

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input

Line 1: Three space-separated integers, respectively:  NM, and  X 
Lines 2.. M+1: Line  i+1 describes road  i with three space-separated integers:  AiBi, and  Ti. The described road runs from farm  Ai to farm  Bi, requiring  Ti time units to traverse.

Output

Line 1: One integer: the maximum of time any one cow must walk.

Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output

10

Hint

Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.

Source




题意:4个村庄,8条有向边,2为起点,问其他村庄到2后又回去,求哪一个村庄浪费的时间最多,只要输出时间


spfa算法其实挺还好,关键是里面的邻接表不好理解


思路: 两次spfa,第一次算出别的村庄来的时间,第二次反向建边,反向建边是说到达此点的点有哪些然后更新那些点,

在一次强调,里面的邻接表不好理解,献血邻接表再学spfa


直接上代码了



#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
using namespace std;
#define N 10005
#define maxe 0x3f3f3f3f

int n,m,x;
int vis[N],dis[N];
int head[N];
int num;
int temp[N];

struct stud1{
int s,e,w;
}ss[N*2];

struct stud{
int to,w,next;
}ee[N*2];

void build(int u,int v,int w)
{
    ee[num].to=v;
    ee[num].w=w;
    ee[num].next=head[u];
    head[u]=num;
    num++;
}

void spfa(int x)
{
    int i,j;
    for(i=1;i<=n;i++)
    {
        dis[i]=maxe;
        vis[i]=0;
    }

    dis[x]=0;
    vis[x]=1;

    queue<int>q;
    q.push(x);

    int cur;
    while(!q.empty())
    {
        cur=q.front();
        q.pop();
        vis[cur]=0;

        for(i=head[cur];i!=-1;i=ee[i].next)
        {
            if(dis[ee[i].to]>dis[cur]+ee[i].w)
            {
                dis[ee[i].to]=dis[cur]+ee[i].w;
                if(!vis[ee[i].to])
                {
                    q.push(ee[i].to);
                    vis[ee[i].to]=1;
                }
            }
        }
    }

    for(i=1;i<=n;i++)
       temp[i]+=dis[i];
}

int main()
{
    int i,j;
    while(~scanf("%d%d%d",&n,&m,&x))
    {
     num=0;
     for(i=1;i<=n;i++)
     {
         temp[i]=0;
         head[i]=-1;
     }

     for(i=0;i<m;i++)
        {
            scanf("%d%d%d",&ss[i].s,&ss[i].e,&ss[i].w);
            build(ss[i].s,ss[i].e,ss[i].w);
        }

        spfa(x);

        num=0;
       for(i=1;i<=n;i++)
        head[i]=-1;

        for(i=0;i<m;i++)
          build(ss[i].e,ss[i].s,ss[i].w);

        spfa(x);

        j=1;
        for(i=2;i<=n;i++)
            if(temp[i]>temp[j])
            j=i;
        printf("%d\n",temp[j]);
    }
    return 0;
}






  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值