POJ 1094 Sorting It All Out(topsort Language: Sorting It All Out Time Limit: 1000MS Memory Limit: )

Language:
Sorting It All Out
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 28241 Accepted: 9757

Description

An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.

Input

Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character "<" and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.

Output

For each problem instance, output consists of one line. This line should be one of the following three: 

Sorted sequence determined after xxx relations: yyy...y. 
Sorted sequence cannot be determined. 
Inconsistency found after xxx relations. 

where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy...y is the sorted, ascending sequence. 

Sample Input

4 6
A<B
A<C
B<C
C<D
B<D
A<B
3 2
A<B
B<A
26 1
A<Z
0 0

Sample Output

Sorted sequence determined after 4 relations: ABCD.
Inconsistency found after 2 relations.
Sorted sequence cannot be determined.

Source




解释在代码中:


#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
#include<queue>
#include<stack>
using namespace std;

#define N 300

int a[N][N],d[N];
int ans[N];
int n,m;

int topsort()
{
	int i,j=0;
	int in[N];
	memcpy(in,d,sizeof(d));      //注意把入度复制到另外一个数组
    stack<int>q;

	for(i=1;i<=n;i++)
		if(in[i]==0)
		q.push(i);

	int x,flag=0;

	while(!q.empty())
	{
      if(q.size()>1) flag=1;
	  x=q.top();
	  q.pop();
	  ans[j++]=x;

	  for(i=1;i<=n;i++)
		if(a[x][i])
	  {
	  	if(--in[i]==0)
			q.push(i);
	  }
	}
	if(j!=n) return 2;
	if(flag) return 0;
	return 1;

}

void print()
{
	int i;
	for(i=0;i<n;i++)
		printf("%c",ans[i]+'A'-1);
	printf(".\n");
}



int main()
{
    int i,j,yes,cut;
    char x,y;
    while(scanf("%d%d",&n,&m),n+m)
	{

        getchar();

	    memset(a,0,sizeof(a));
		memset(d,0,sizeof(d));
        yes=0;
		for(i=1;i<=m;i++)
		{
			scanf("%c<%c",&x,&y);
			getchar();

			if(a[x-'A'+1][y-'A'+1])
               	continue;

            if(yes) continue;

		    a[x-'A'+1][y-'A'+1]=1;
			d[y-'A'+1]++;
			yes=topsort();
			if(yes)
				cut=i;

		}

		 if(yes==1)
			{
				printf("Sorted sequence determined after %d relations: ",cut);
				print();
			}
            else
				if(yes==2)
			{
				printf("Inconsistency found after %d relations.\n",cut);
				i=n+1;
			}
			else
            if(yes==0)
				printf("Sorted sequence cannot be determined.\n");
	}
	return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值