HDU 5108Alexandra and Prime Numbers(大素数)

Problem Description
Alexandra has a little brother. He is new to programming. One day he is solving the following problem: Given an positive integer N, judge whether N is prime.
The problem above is quite easy, so Alexandra gave him a new task: Given a positive integer N, find the minimal positive integer M, such that N/M is prime. If such M doesn't exist, output 0.
Help him!
 

Input
There are multiple test cases (no more than 1,000). Each case contains only one positive integer N.
N1,000,000,000 .
Number of cases with N>1,000,000 is no more than 100.
 

Output
For each case, output the requested M, or output 0 if no solution exists.
 

Sample Input
  
  
3 4 5 6
 

Sample Output
  
  
1 2 1 2
 


对于此题,我只想说自己好傻的,对于一个大数n,求最小的m是的n/m是素数


首先  n=素数*素数*素数......


那么我们求最大的素数,还有这个素数中不可能有两个大于sqrt(n)的,那么代码如下


#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
#include<cmath>

#define L(x) (x<<1)
#define R(x) (x<<1|1)
#define MID(x,y) ((x+y)>>1)

using namespace std;
typedef __int64 ll;

#define N 100000

ll a[N],b[N];
ll k;

void inset()
{
	int i,j;
	a[0]=1;
	for(i=2;i<N;i++)
		if(!a[i])
		{
			for(j=i*2;j<N;j+=i)
			    a[j]=1;
			b[k++]=i;
		}

}

int main()
{
	int i,j;

	inset();
	ll n,temp;
	while(~scanf("%I64d",&n))
	{
		if(n==1)
		{
			printf("0\n");
			continue;
		}

		int flag=0;
        temp=n;
		ll m=(ll)(sqrt(n))+1;

        ll ans=0;

		for(m;m>1;m--)
			if(n%m==0)
		  {
			 while(n%m==0&&!a[m])
				n/=m;

			 if(!a[m])
			 {
			 	ans=max(ans,m);
			 }
		  }
		ans=(ll)max(ans,n);
		printf("%I64d\n",temp/ans);
	}
	return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值