POJ 3254 Corn Fields (状压)

Language:
Corn Fields
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 8704 Accepted: 4641

Description

Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can't be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

Input

Line 1: Two space-separated integers:  M and  N 
Lines 2.. M+1: Line  i+1 describes row  i of the pasture with  N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)

Output

Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.

Sample Input

2 3
1 1 1
0 1 0

Sample Output

9

Hint

Number the squares as follows:
1 2 3
  4  

There are four ways to plant only on one squares (1, 2, 3, or 4), three ways to plant on two squares (13, 14, or 34), 1 way to plant on three squares (134), and one way to plant on no squares. 4+3+1+1=9.

Source


下面链接题解很清楚


参考链接 : http://www.cnblogs.com/void/articles/2072601.html




#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<stack>
#include<vector>
#include<set>
#include<map>


#define L(x) (x<<1)
#define R(x) (x<<1|1)
#define MID(x,y) ((x+y)>>1)

#define eps 1e-8
typedef __int64 ll;

#define fre(i,a,b)  for(i = a; i <b; i++)
#define fro(i,a,b)  fro(i = b; i >=a; i--)
#define mem(t, v)   memset ((t) , v, sizeof(t))

#define sfs(a)      scanf("%s", a);
#define sf(n)       scanf("%d", &n)
#define sff(a,b)    scanf("%d %d", &a, &b)
#define sfff(a,b,c) scanf("%d %d %d", &a, &b, &c)

#define pf          printf
#define bug         pf("Hi\n")

using namespace std;

#define INF 0x3f3f3f3f
#define N 1<<12

#define mod 100000000

int dp[12][N],h[N],type[N];
int num,n,m;


bool judge(int x)
{
	if(x&(x<<1)) return false;
	return true;
}

void inint()
{

	int len=1<<m,i;

    fre(i,0,len)
       if(judge(i))
		type[num++]=i;

}

int main()
{
	int i,j,t;
	while(~sff(n,m))
	{
		mem(h,0);
		fre(i,0,n)
		  fre(j,0,m)
		  {
		  	int x;
		  	sf(x);
		  	if(x==0) h[i]|=1<<j;
		  }

		num=0;
		inint();

	   mem(dp,0);
       fre(i,0,num)
        if((h[0]&type[i])==0)
		{
			dp[0][i]=1;
		}

	   fre(i,1,n)
	     fre(j,0,num)
	     {
	     	if(h[i]&type[j]) continue;

            fre(t,0,num)
            {
            	if((h[i-1]&type[t])||(type[j]&type[t]))  continue;
            	dp[i][j]=(dp[i][j]+dp[i-1][t])%mod;

            }
	     }

	int ans=0;

	fre(i,0,num)
	  ans=(ans+dp[n-1][i])%mod;
	pf("%d\n",ans);

	}

	return 0;
}




  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值