HDU 5113 Black And White (dfs)

Black And White

Time Limit: 2000/2000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)
Total Submission(s): 1707    Accepted Submission(s): 462
Special Judge


Problem Description
In mathematics, the four color theorem, or the four color map theorem, states that, given any separation of a plane into contiguous regions, producing a figure called a map, no more than four colors are required to color the regions of the map so that no two adjacent regions have the same color.
— Wikipedia, the free encyclopedia

In this problem, you have to solve the 4-color problem. Hey, I’m just joking.

You are asked to solve a similar problem:

Color an N × M chessboard with K colors numbered from 1 to K such that no two adjacent cells have the same color (two cells are adjacent if they share an edge). The i-th color should be used in exactly c i cells.

Matt hopes you can tell him a possible coloring.
 

Input
The first line contains only one integer T (1 ≤ T ≤ 5000), which indicates the number of test cases.

For each test case, the first line contains three integers: N, M, K (0 < N, M ≤ 5, 0 < K ≤ N × M ).

The second line contains K integers c i (c i > 0), denoting the number of cells where the i-th color should be used.

It’s guaranteed that c 1 + c 2 + · · · + c K = N × M .
 

Output
For each test case, the first line contains “Case #x:”, where x is the case number (starting from 1). 

In the second line, output “NO” if there is no coloring satisfying the requirements. Otherwise, output “YES” in one line. Each of the following N lines contains M numbers seperated by single whitespace, denoting the color of the cells.

If there are multiple solutions, output any of them.
 

Sample Input
  
  
4 1 5 2 4 1 3 3 4 1 2 2 4 2 3 3 2 2 2 3 2 3 2 2 2
 

Sample Output
  
  
Case #1: NO Case #2: YES 4 3 4 2 1 2 4 3 4 Case #3: YES 1 2 3 2 3 1 Case #4: YES 1 2 2 3 3 1
 

Source
 

Recommend
liuyiding   |   We have carefully selected several similar problems for you:   5426  5425  5424  5423  5422 
 


自以为找规律很完美,wa成狗,搜了题解 -> 搜索



#pragma comment(linker, "/STACK:1024000000,1024000000")
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<stack>
#include<vector>
#include<set>
#include<map>

#define L(x) (x<<1)
#define R(x) (x<<1|1)
#define MID(x,y) ((x+y)>>1)

#define bug printf("hihi\n")

#define eps 1e-8

typedef long long ll;

using namespace std;

#define mod 1000000007

#define INF 0x3f3f3f3f

#define N 7

int a[N][N],num[N];
int k;
int ans[N][N];
bool flag;
int n,m;

inline bool judge(int x,int y,int i)
{
     if(ans[x-1][y]==i||ans[x][y-1]==i) return false;
     return true;
}

void dfs(int x,int y,int res)
{
      if(res==0) flag=true;
      if(flag) return ;
      if(y==m+1)
      {
          x++;
          y=1;
      }
      for(int i=1;i<=k;i++)
      {
          if((res+1)/2<num[i]) return ;
      }
      for(int i=1;i<=k;i++)
        if(num[i]&&judge(x,y,i))
      {
             ans[x][y]=i;
             num[i]--;
             dfs(x,y+1,res-1);
             if(flag) return ;
             ans[x][y]=0;
             num[i]++;
      }
}

int main()
{
    int i,j,t,ca=0;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d%d",&n,&m,&k);
        memset(ans,0,sizeof(ans));
        for(i=1;i<=k;i++)
            scanf("%d",&num[i]);
        flag=false;
        dfs(1,1,n*m);
        printf("Case #%d:\n",++ca);
        if(!flag)
            printf("NO\n");
        else
        {
            printf("YES\n");
            for(int i=1;i<=n;i++)
            {
                for(j=1;j<=m;j++)
                {
                    if(j!=1) printf(" ");
                    printf("%d",ans[i][j]);
                }
                printf("\n");
            }
        }
    }
    return 0;
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值