排序算法

Problem Description

One of the fundamental problems of computer science is ordering a list of items. There're a plethora of solutions to this problem, known as sorting algorithms. Some sorting algorithms are simple and intuitive, such as the bubble sort. Others, such as the heap sort are not so simple, but produce lightening-fast results.
In the following is a list of some sorting algorithms. Of course, I can’t tell you how to implement them here. You must use your own knowledge.
Bubble sort
Heap sort
Insertion sort
Merge sort
Quick sort
Selection sort
Shell sort

My business here is to give you some numbers, and to sort them is your business. Attention, I want the smallest number at the top of the sorted list.

Input

The input file will consist of series data sets. Each data set has two parts. The first part contains two non-negative integers, n (1<=n<=100,000) and m (1<=m<=n), representing the total of numbers you will get and interval of the output sorted list. The second part contains n positive integers. I am sure that each integer in this part will be less than 2,000,000,000.
The input is terminated by a line with two zeros.

Output

For one data set, you should output several numbers in ONE line. After you get the sorted list, you should output the first number of each m numbers, and you should print exact ONE space between two adjacent numbers. And please make sure that there should NOT be any blank line between outputs of two adjacent data sets.

Sample Input

8 2
3
5
7
1
8
6
4
2
0 0

Sample Output

1 3 5 7

Author

HYNU 
 

题意分析:

先按从小到大排序再按M间隔输出已排好序的数。

代码:

#include<stdio.h>
#include<malloc.h>
#include<algorithm>
#include<iostream>
using namespace std;
int main()
{
   int n,m,*a,i;
   while(scanf("%d%d",&n,&m)!=EOF&&(n!=0||m!=0))
   {
      a=(int *)malloc(sizeof(int)*n);
      for(i=0;i<n;i++)
        scanf("%d",a+i);
      sort(a,a+n); //调用系统自带排序函数
      for(i=0;i<n;i+=m) //按m个字符间隔输出
        if(i==0)printf("%d",a[i]);
        else printf(" %d",a[i]);
      printf("\n");
      free(a);
   }
   return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值