Problem Description
Tom wants to cover a rectangular floor by identical L-shape tiles without overlap. As shown below, the floor can be split into many small squares, and the L-shape tile consists of exactly four small squares. The floor of 3*8 can be completely covered by 6 L-shape tiles, but the floor of 3*7 is impossible.
111 11222344
1 15233364
15556664
Tom would like to know whether an arbitrary floor with n*m small squares can be completely covered or not. He is sure that when n and m are small he can find the answer by paper work, but when it comes to larger n and m, he has no idea to find the answer. Can you tell him?
111 11222344
1 15233364
15556664
Tom would like to know whether an arbitrary floor with n*m small squares can be completely covered or not. He is sure that when n and m are small he can find the answer by paper work, but when it comes to larger n and m, he has no idea to find the answer. Can you tell him?
Input
The input file will consist of several test cases. Each case consists of a single line with two positive integers m and n (1<=m<=15, 1<=n<=40).
The input is ended by m=n=0.
The input is ended by m=n=0.
Output
For each case, print the word ‘YES’ in a single line if it is possible to cover the m*n floor, print ‘NO’ otherwise.
Sample Input
3 8
3 7
0 0
Sample Output
YES
NO
Author
/*
题意大概:给你一个n*m的矩形,问你是否有办法用“L”覆盖。
由“L”组成的最小矩形为2*4或者4*2。其他能够被“L”覆盖的矩形都能用这两种矩形组成。所以只要n*m%8==0且n和m不为1就是YES的。
*/
#include<stdio.h>
int main()
{
int n,m;
while(scanf("%d%d",&n,&m)!=EOF&&(n||m))
{
if(n>1&&m>1&&n*m%8==0) printf("YES\n");
else printf("NO\n");
}
return 0;
}