HOJ 12822 The Alphabet Sticker

The Alphabet Sticker
Time Limit: 10000ms, Special Time Limit:25000ms, Memory Limit:65536KB
Total submit users: 70, Accepted users: 58
Problem 12822 : No special judgement
Problem description

When we were kids, we used to play with some stickers where these stickers contain some (but not necessarily all) lower case English alphabet letters.

Each sticker contains some letters arranged in a single row, where all occurrences of the same letter are adjacent to each other. A sticker can be represented as a string of characters, for example the following are valid stickers’ representations: “aabcc”, “ccccab” and “mmaw”. And the following are not valid (because not all occurrences of the same letter are adjacent to each other): “abacc”, “cccabc” and “mawm”.

Now we found some stickers with some missing letters, but we are sure that all missing letters belong to the visible letters set (that is, for every missing letter, there is at least one visible letter that matches the missing one). In this problem a question mark letter represents a missing letter. Given some stickers’ representations with zero or more missing letters, your task is to count the number of possible original configurations for each sticker.

For example, this sticker “aa??bb” with missing letters could have been one of the following original stickers “aaaabb”, “aaabbb” or “aabbbb”. But it could not have been any of the following original stickers “aababb” (it is invalid sticker) and “aaccbb” (because the letter ‘c’ did not appear in the given configuration).


Input

Your program will be tested on one or more test cases. The first line of the input will be a single integer T, the number of test cases T ranges in(1,100). Followed by the test cases, each test case is described in one line which contains a non-empty string which consists of up to 10,000 letters, each letter is either a lower case English letter (from ‘a’ to ‘z’) or a question mark (‘ ?’). This string represents a sticker configuration which contains zero or more question marks, it will also contain at least one letter which is not a question mark and there will be at least one valid original configuration for it.


Output

For each test case, print a single line which contains a single integer representing the number of possible original configurations for the sticker, since the result may be very large, print it modulo 1,000,000,007 (10^9 + 7).


Sample Input
4
aa??bb
aaccbb
?a?
a??a
Sample Output
3
1
1
1
分三种情况:

1:头部的?和尾部的问号?不用处理,只有与?临近的那个字母相同这一种情况。

2:中间没问号了的,那就一种情况了。

3:中间的问号如果问号串左右两边的字母相同,那就只有一种情况,不用处理;如果不同,那就是问号的个数+1种情况,有多个这种串相乘即可。

AC代码:

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<iostream>
using namespace std;
const int N = 1e9 + 7;
char str[100005];
int main()
{
 //   freopen("A.in", "r", stdin);
    int t;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%s", str);
        int len = strlen(str);
        int  i, j;
        for(i = 0; i < len - 1; i++)
            if(str[i] != '?')
                break;
        for(j = len - 1; j > 0; j--)
            if(str[j] != '?')
                break;
        if(i == j)
        {
            printf("1\n");
            continue;
        }
        long long sum = 1;
        long long cnt = 0;
        char pre = str[i];
        for(; i <= j; i++)
        {
            if(str[i] != '?')
            {
                if(cnt && pre != str[i])
                {
                    sum = (sum * ((cnt + 1) % N)) % N;
                }
                pre = str[i];
                cnt = 0;
            }
            else
                cnt++;
        }
        printf("%lld\n", sum);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值