HOJ 1050 TO the sum

 

http://poj.org/problem?id=1088

 

To the Max

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 52615 Accepted: 27849

Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle. 
As an example, the maximal sub-rectangle of the array: 

0 -2 -7 0 
9 2 -6 2 
-4 1 -4 1 
-1 8 0 -2 
is in the lower left corner: 

9 2 
-4 1 
-1 8 
and has a sum of 15. 

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4  1 -1

8  0 -2

Sample Output

15

Source

Greater New York 2001

 

#include<iostream>
#include<cstring>
using namespace std;
int a[105][105],sum[105],b[105];
int main()
{
    int n;
    while(cin>>n)
    {
        for(int i=1; i<=n; i++)
        {
            for(int j=1; j<=n; j++)
            {
                cin>>a[i][j];
            }
        }
        memset(sum,0,sizeof(sum));
        int max=-100000;//建一个最小的数 
        for(int i=1; i<=n; i++)//先从第一行开始找与第一行有关的最大子矩阵; 
        {                       //再从第二行开始找从第二行开始的最大矩阵; 
            memset(sum,0,sizeof(sum));//将sun 和 b数组都初始化为0 
            memset(b,0,sizeof(b));
            for(int k=i; k<=n; k++)
            {
                for(int j=1; j<=n; j++)
                {
                    b[j]+=a[k][j];
                    if(sum[j-1]>=0)//这步意思是只要大于1,也就是可以让和增大我就把你加上 
                        sum[j]=sum[j-1]+b[j];
                    else          //如果开始减小了就与前面的断掉关系重新开始累加 
                        sum[j]=b[j];
                    if(max<sum[j])
                        max=sum[j];//实时记录,更新最大值; 
                }
            }
        }
        cout<<max<<endl;
    }
    return 0;
}


 

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值