Find Integer

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1453    Accepted Submission(s): 479
Special Judge

 

Problem Description

people in USSS love math very much, and there is a famous math problem .

give you two integers n ,a ,you are required to find 2 integers b ,c such that an +bn=cn .

 

 

Input

one line contains one integer T ;(1≤T≤1000000)

next T lines contains two integers n ,a ;(0≤n≤1000 ,000 ,000,3≤a≤40000)

 

 

Output

print two integers b ,c if b ,c exits;(1≤b,c≤1000 ,000 ,000) ;

else print two integers -1 -1 instead.

 

 

Sample Input

 

1 2 3

 

 

Sample Output

 

4 5

 

 

Source

2018中国大学生程序设计竞赛 - 网络选拔赛

 

 

Recommend

chendu   |   We have carefully selected several similar problems for you:  6447 6446 6445 6444 6443 

 

其中涉及到的主要知识就是费马大定理,和一些求勾股数的公式;

 

#include <iostream>
using namespace std;
typedef unsigned long long int LL;
int main()
{
	int t;
	LL a, n;
	LL b, c;
	
	scanf("%d", &t);
	while (t--) {
		scanf("%lld%lld", &n, &a);
		if (n > 2) {//费马大定理
			printf("-1 -1\n");
			continue;
		}
		else if (n == 2) {
			if (a % 2 == 1) {//如果为奇数
				LL k;
				k= (a - 1) / 2;      /* k,b,c都是套的求勾股数的公式*/
				b = 2 * k*k + 2 * k;
				c = 2*k*k+2*k+1;
				printf("%lld %lld\n", b, c);
				continue;
			}
			else {//如果为偶数
				LL k;
				k = a / 2;             /*同理,也是套公式*/
				b = k * k - 1;
				c = k * k + 1;
				printf("%lld %lld\n", b, c);
				continue;
			}

		}
		else if(n==1){
			cout << 1 << ' ' << a + 1 << endl;
			continue;
		}
		else {//当n等于0的时候
			cout << "-1 -1" << endl;
			continue;
		}

	}


	return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值