people in USSS love math very much, and there is a famous math problem .
give you two integers n,a,you are required to find 2 integers b,c such that an+bn=cn
.
Input
one line contains one integer T;(1≤T≤1000000)
next T lines contains two integers n,a;(0≤n≤1000,000,000,3≤a≤40000)
Output
print two integers b,c if b,c exits;(1≤b,c≤1000,000,000);
else print two integers -1 -1 instead.
Sample Input
1
2 3
Sample Output
4 5
思路:
根据费马大定理可得n>=3时无解,排除。根据勾股数的规律,可得当原数可被2整除时,b c为原数平方处以4的上下两数,当原数为奇数时,b c 为原数平方除2,与其加1
代码
#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <queue>
#include <algorithm>
using namespace std;
typedef long long ll;
int main()
{
int T;
scanf("%d",&T);
while(T--)
{
ll n,a;
scanf("%lld %lld",&n,&a);
if(n>2 || n==0)
{
printf("-1 -1\n");
}
else if(n==2)
{
ll temp=a*a;
temp/=2;
if(a%2==1) printf("%lld %lld\n",temp,temp+1);
else printf("%lld %lld\n",temp/2-1,temp/2+1);
}
else if(n==1)
{
printf("1 %lld\n",a+1);
}
}
return 0;
}