Problem
Given N integers, you are supposed to find the smallest positive integer that is NOT in the given list.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤10^5). Then N integers are given in the next line, separated by spaces. All the numbers are in the range of int.
Output Specification:
Print in a line the smallest positive integer that is missing from the input list.
Sample Input:
10
5 -25 9 6 1 3 4 2 5 17
Sample Output:
7
Method
This problem is quite easy to solve except for the for last test point, which may casue segmentation fault. The reason for that is a number in the last case exceeds the maximun of array element subscript.
But it is easy to solve. As we know, we can set a huge number INF as the maximun of array element subscript. When a number is inputed, firstly we should check if it exceeds INF. If yes, just ignore it. If not, set that number acted as the index of the array, as true. In the end, we can check the number from 1. When we find the first number acted as the index of the array that is false in the group, that is the answer.
【Code】
#include<bits/stdc++.h>
using namespace std;
const int INF = 1000000005;
bool num[INF];
int main()
{
int n, t;
scanf("%d", &n);
for(int i = 0; i < n; i++)
{
scanf("%d", &t);
if(t >= 0 && t < INF)
num[t] = true;
}
int k = 1;
while(1)
{
if(!num[k])
break;
k++;
}
printf("%d\n", k);
return 0;
}