acm pku 1258 Agri-Net的Prim算法实现

Agri-Net

Description

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course.
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms.
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm.
The distance between any two farms will not exceed 100,000.

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

4

0 4 9 21

4 0 8 17

9 8 0 16

21 17 16 0

Sample Output

28

Source

USACO 102

 

分析:这道题目的直观意思是,求出包含所有“farms”的路径,并且这些路径之和最小。自然地,我想到了最小生成树的问题,而这道题目恰恰就是一道关于最小生成树的构造问题。

由于最多具有N=100个“farms”而最小生成树Prim算法的时间复杂度为O(N^3),因此,可以直接使用Prim算法解决这道题目。

 

代码实现:

#include <string.h>

#include "iostream"

using namespace std;

 

#define N 100

int num, itg[N][N];

 

long MinimumLen(void)

{

       long sum = 0, imin;

       int i, j, index, init[2];

       int *id = new int[num], idnum = 0;

       bool *bflag = new bool[num];

 

       memset(bflag, false, sizeof(bool)*num);

       imin = 100001;

       for(i = 0; i < num; i++) // find out the least fiber among all farms;

       {

              for(j = 0; j < num; j++)

              {

                     if(imin > itg[i][j])

                     {

                            imin = itg[i][j];

                            init[0] = i;

                            init[1] = j;

                     }

              }

       }

       id[0] = init[0];

       id[1] = init[1];

       idnum = 2;

       bflag[id[0]] = true;

       bflag[id[1]] = true;

       sum += imin;

 

       while(idnum < num) //find out the other num-2 "minimum" connectable fiber

       {

              imin = 100001;

              for(i = 0; i < num; i++)

              {

                     if(!bflag[i])

                     {

                            for(j = 0; j < idnum; j++)

                            {

                                   if(imin > itg[i][id[j]])

                                   {

                                          imin = itg[i][id[j]];

                                          index = i;

                                   }

                            }

                     }

              }

              sum += imin;

              bflag[index] = true;

              id[idnum] = index;

              idnum++ ;

       }

 

       delete [] id;

       delete [] bflag;

       return sum;

}

 

int main(void)

{

       int i, j;

 

       while(cin >> num)

       {

              for(i = 0; i < num; i++)

              {

                     for(j = 0; j < num; j++)

                            cin >> itg[i][j];

                     itg[i][i] = 100001;

              }

              cout << MinimumLen() << endl;

       }

       return 0;

}

 

提交结果:

Problem: 1258

 

User: uestcshe

Memory: 280K

 

Time: 63MS

Language: C++

 

Result: Accepted

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值