POJ 1258 Agri-Net(最小生成树prim算法)

Agri-Net
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 39070 Accepted: 15822

Description

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course.
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms.
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm.
The distance between any two farms will not exceed 100,000.

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

Sample Output

28

 

 

/*没啥说的,就是对于一个有n个结点的有权无向图,
给出一个n×n的数组表示相应的结点之间的距离
最后求最小生成树的代价*/
#include<iostream>
#include<cstdio>
#include<cstring>//因为用了memset函数
#define MaxInt 200000//因为两个村庄间的最大距离不超过100000,再者宏定义不要加分号
using namespace std;
const int maxn=105;
int map[maxn][maxn];//储存图标内的每两个点之间的距离信息
int visit[maxn];//用来标识结点是否被访问过
int low[maxn];// 在prim算法进行的过程中记录每2点间的最小权值
int n;//n为村庄的个数
int main()
{
 int prim(void);
 int i,j;
 while(cin>>n)
 {
  //下面的这一句将map的每个元素设置为无穷大的句子是可以省略的
  memset(map,MaxInt,sizeof(map));//所有权值初始化为最大
  for(i=1;i<=n;i++)
   for(j=1;j<=n;j++)
   {scanf("%d",&map[i][j]);}
  int ans=prim();
  cout<<ans<<endl;
 }
 return 0;
}

int prim()
{
 int i,j,pos,min,ans=0;
 //将标记数组初始化为所有的点均未被访问过
 memset(visit,0,sizeof(visit));
 //从1点开始,分别标记和记录该点
 visit[1]=1;pos=1;
 //第一次给low数组赋值
 for(i=1;i<=n;i++)
 {if(i!=pos){low[i]=map[pos][i];}}
 //再运行n-1次
 for(i=1;i<n;i++)
 {
  //找出最小权值并记录位置
  min=MaxInt;
  for(j=1;j<=n;j++)
  {
   if(visit[j]==0&&min>low[j])//在没有访问的点里面选出权值最小的位置
   {min=low[j];pos=j;}//用pos记录下下一个权值最小点的位置
  }
  /*上面的pos实际上记载了点的选取过程,如果要输出点的选出过程,可以在这里加一个输出pos语句*/
  //最小权值累加
  ans+=min;
  //标记当前新的起点为被访问过
  visit[pos]=1;
  //更新权值
  for(j=1;j<=n;j++)
   if(visit[j]==0&&low[j]>map[pos][j])
   {low[j]=map[pos][j];}
 }
 return ans;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值