acm pku 1287 Networking的Prim最小生成树算法实现

Networking

Description

You are assigned to design network connections between certain points in a wide area. You are given a set of points in the area, and a set of possible routes for the cables that may connect pairs of points. For each possible route between two points, you are given the length of the cable that is needed to connect the points over that route. Note that there may exist many possible routes between two given points. It is assumed that the given possible routes connect (directly or indirectly) each two points in the area.
Your task is to design the network for the area, so that there is a connection (direct or indirect) between every two points (i.e., all the points are interconnected, but not necessarily by a direct cable), and that the total length of the used cable is minimal.

Input

The input file consists of a number of data sets. Each data set defines one required network. The first line of the set contains two integers: the first defines the number P of the given points, and the second the number R of given routes between the points. The following R lines define the given routes between the points, each giving three integer numbers: the first two numbers identify the points, and the third gives the length of the route. The numbers are separated with white spaces. A data set giving only one number P=0 denotes the end of the input. The data sets are separated with an empty line.
The maximal number of points is 50. The maximal length of a given route is 100. The number of possible routes is unlimited. The nodes are identified with integers between 1 and P (inclusive). The routes between two points i and j may be given as i j or as j i.

Output

For each data set, print one number on a separate line that gives the total length of the cable used for the entire designed network.

Sample Input

1 0
 
2 3
1 2 37
2 1 17
1 2 68
 
3 7
1 2 19
2 3 11
3 1 7
1 3 5
2 3 89
3 1 91
1 2 32
 
5 7
1 2 5
2 3 7
2 4 8
4 5 11
3 5 10
1 5 6
4 2 12
 
0

Sample Output

0
17
16
26

Source

Southeastern Europe 2002

 

 

分析:题目大意是找到联通所有节点且具有最小路径和的方案,并返回最小路径和,归根结底,这又是一道最小生成树的问题。Prim最小生成树算法是一个很好的选择。

在代码实现时,由于同样的路径具有多种不同的权重,因此,需要存储具体两节点间的最小路径权重,Prim算法的基本思想是:先找出整个网络中,具有最小节点路径的两个点,构成一个包,这后不断从网络中向这个保重加入节点,知道所有网络中的节点都加入该包为止。在将节点加入包时,始终选择当前网络中到包距离最近的节点加入。

 

代码实现:

#include <string.h>

#include "iostream"

using namespace std;

 

#define N 51

int itg[N][N];

 

int PrimTree( int P )

{

       bool bflag[N];

       int res = 0;

       int i, j, k, imin, index[2];

 

       memset( bflag, false, sizeof(bool)*N );

       //initilize

       imin = 1000;

       if(P > 1)

       {

              for(i = 1; i <= P; i++)

              {

                     for(j = i+1; j <= P; j++)

                     {

                            if( itg[i][j] != 0 && imin > itg[i][j] )

                            {

                                   imin = itg[i][j];

                                   index[0] = i;

                                   index[1] = j;

                            }

                     }

              }

              res += imin;

              bflag[index[0]] = true;

              bflag[index[1]] = true;

       }

 

       k = 2;

       while(k++ < P)

       {

              imin = 1000;

              for(i = 1; i <= P; i++)

              {

                     if(bflag[i])

                     {

                            for(j = 1; j <= P; j++)

                            {

                                   if( !bflag[j] && itg[i][j] != 0 && imin > itg[i][j] )

                                   {

                                          imin = itg[i][j];

                                          index[1] = j;

                                   }

                            }

                     }

              }

              res += imin;

              bflag[index[1]] = true;

       }

 

       return res;

}

 

int main(void)

{

       int P, R;

       int i, iR, itemp, ibegin, iend, ivalue;

 

       cin >> P;

       while(P != 0)

       {

              cin >> R;

              for(i = 0; i < N; i++)

                     memset(itg[i], 0, sizeof(int)*N);

              iR = 0;

 

              for(i = 0; i < R; i++)

              {

                     cin >> ibegin >>  iend >> ivalue;

                     if(ibegin > iend)

                     {

                            itemp = ibegin;

                            ibegin = iend;

                            iend = itemp;

                     }

                     if(itg[ibegin][iend] == 0 || ( itg[ibegin][iend] != 0 && itg[ibegin][iend] > ivalue ) )

                            itg[ibegin][iend] = ivalue;

                     itg[iend][ibegin] = itg[ibegin][iend];

              }

 

              cout << PrimTree(P) << endl;

 

              cin >> P;

       }

       return 0;

}

 

提交结果:

 

Problem: 1287

 

User: uestcshe

Memory: 248K

 

Time: 94MS

Language: C++

 

Result: Accepted

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值