Decode the Tree_priority_queue_STL_2018_2_19

10 篇文章 0 订阅
3 篇文章 0 订阅
A tree (i.e. a connected graph without cycles) with vertices numbered by the integers 1, 2, ..., n is given. The "Prufer" code of such a tree is built as follows: the leaf (a vertex that is incident to only one edge) with the minimal number is taken. This leaf, together with its incident edge is removed from the graph, while the number of the vertex that was adjacent to the leaf is written down. In the obtained graph, this procedure is repeated, until there is only one vertex left (which, by the way, always has number n). The written down sequence of n-1 numbers is called the Prufer code of the tree.

Your task is, to reconstruct a tree, given its Prufer code. The tree should be denoted by a word of the language specified by the following grammar:

T ::= "(" N S ")"
S ::= " " T S
| empty
N ::= number

That is, trees have parentheses around them, and a number denoting the identifier of the root vertex, followed by arbitrarily many (maybe none) subtrees separated by a single space character. As an example, take a look at the tree in the figure below which is denoted in the first line of the sample output.


Note that, according to the definition given above, the root of a tree may be a leaf as well. It is only for the ease of denotation that we designate some vertex to be the root. Usually, what we are dealing here with is called an "unrooted tree".


Input

The input contains several test cases. Each test case specifies the Prufer code of a tree on one line. You will find n-1 numbers separated by a single space. Input is terminated by EOF. You may assume that 1 <= n <= 50.


Output

For each test case generate a single line containing the corresponding tree, denoted as described above. Note that, in general, there are many ways to denote such a tree: choose your favourite one.


Sample Input


5 2 5 2 6 2 8
2 3
2 1 6 2 6


Sample Output

(8 (2 (3) (5 (1) (4)) (6 (7))))
(3 (2 (1)))

(6 (1 (4)) (2 (3) (5)))

#include<iostream> 
#include<cstdio>
#include<queue>
#include<strstream>
#include<vector>
#include<string>
using namespace std;

typedef vector<int> vi;
typedef vector<vi> vvi;

void print(vvi &adj,int x,int p=0){
	printf("(%d",x) ;
	for(vi::iterator it=adj[x].begin();it!=adj[x].end();it++)
	if(*it!=p){
		putchar(' ');
		print(adj,*it,x);
	}
	putchar(')');
}

int main(){
	string line;
	while(getline(cin,line)){
		istrstream lstr(line.c_str());
		vi v;
		int x;
		while(lstr>>x)
		v.push_back(x);
		int n=v.size()+1;
		vi deg(n+1,0);
		for(int i=0;i<n-1;i++)
		deg[v[i]]++;
		priority_queue<int,vi,greater<int> >leafs;
		for(int i=1;i<=n;i++)
		if(deg[i]==0)leafs.push(i);
		vvi adj(n+1,vi());
		for(int i=0;i<n-1;i++){
			x=leafs.top();
			leafs.pop();
			adj[x].push_back(v[i]);
			adj[v[i]].push_back(x);
			if(--deg[v[i]]==0)leafs.push(v[i]);
		}
		print(adj,n);
		puts("");
	}
}









  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值