1020. Tree Traversals (25)_2018_3_24

16 篇文章 0 订阅

1020. Tree Traversals (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
Sample Output:
4 1 6 3 5 7 2

提交代码

#include<bits/stdc++.h>
using namespace std;

const int N(35);
int a[N],b[N];
int cnt; 

struct AA{
	int a;
	int val;
	AA(){}
	AA(int aa,int vv):a(aa),val(vv){}
};

AA ans[N];
int cmp(AA a,AA b){
	return a.val<b.val;
}

void solve(int la,int ra,int lb,int rb,int w){
	if(la>ra)return;
	if(la==ra){
		ans[cnt++]=AA(a[ra],w);
		return;
	}
	ans[cnt++]=AA(a[ra],w);
	int i=lb;
	for(;i<=rb;i++)
	if(a[ra]==b[i])break;
	solve(la,la+i-lb-1,lb,i-1,w+1);
	solve(la+i-lb,ra-1,i+1,rb,w+1);
}

int main(){
	int n;
	scanf("%d",&n);
	for(int i=0;i<n;i++)
	scanf("%d",&a[i]);
	for(int i=0;i<n;i++)
	scanf("%d",&b[i]);
	cnt=0;
	solve(0,n-1,0,n,0);
	stable_sort(ans,ans+cnt,cmp);
	for(int i=0;i<cnt;i++)
	if(i==0)printf("%d",ans[i].a);
	else printf(" %d",ans[i].a);
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值