Bless You Autocorrect! 字典树+bfs

Bless You Autocorrect!

 

Typing on phones can be tedious. It is easy to make typing mistakes, which is why most phones come with an autocorrect feature. Autocorrect not only fixes common typos, but also suggests how to finish the word while you type it. Jenny has recently been pondering how she can use this feature to her advantage, so that she can send a particular message with the minimum amount of typing.
The autocorrect feature on Jenny’s phone works like this: the phone has an internal dictionary of words sorted by their frequency in the English language. Whenever a word is being typed,autocorrect suggests the most common word (if any) starting with all the letters typed so far. By pressing tab, the word being typed is completed with the autocorrect suggestion. Autocorrect can only be used after the first character of a word has been typed –it is not possible to press tab before having typed anything. If no dictionary word starts with the letters typed so far, pressing tab has no effect.
Jenny has recently noticed that it is sometimes possible to use autocorrect to her advantage even when it is not suggesting the correct word, by deleting the end of the autocorrected word. For instance, to type the word “autocorrelation”, Jenny starts typing “aut”, which then autocorrects to “autocorrect” (because it is such a common word these days!) when pressing tab. By deleting the last two characters (“ct”) and then typing the six letters “lation”, the whole word can be typed using only 3 (“aut”) + 1 (tab) + 2 (backspace twice) + 6 (“lation”) = 12 keystrokes, 3 fewer than typing “autocorrelation” without using autocorrect.
Given the dictionary on the phone and the words Jenny wants to type, output the minimum number of keystrokes required to type each word. The only keys Jenny can use are the letter keys, tab and backspace.

 

输入

The first line of input contains two positive integers n (1 ≤ n ≤ 105 ), the number of words in the dictionary, and m (1 ≤ m ≤ 10 5 ), the number of words to type. Then follow n lines with one word per line, sorted in decreasing order of how common the word is (the first word is the most common). No word appears twice in the dictionary. Then follow m lines, containing the words to type.
The dictionary and the words to type only use lower case letters ‘ a ’-‘ z ’. The total size  of the input file is at most 1 MB.

 

输出

For each word to type, output a line containing the minimum number of keystrokes required to type the corresponding word.

 

样例输入

5 5
austria
autocorrect
program
programming
computer
autocorrelation
programming
competition
zyx
austria

 

样例输出

12
4
11
3
2
#include<bits/stdc++.h> 
using namespace std;
#define rep(i,s,t) for(int i=s;i<t;++i)
#define repb(i,s,t) for(int i=s;i<=t;i++)
#define mst(a,b) memset(a,b,sizeof(a)) 
#define pb push_back
#define maxn 1100004
const int inf =0x3f3f3f3f; 

vector<int> N[maxn];
int dis[maxn*2],inq[maxn*2];

struct trie{
	int ch[maxn][26],val[maxn],cnt[maxn],fa[maxn],ed[maxn],sz;
	void init(){sz=0;mst(cnt,0);mst(ch,0);mst(val,0);mst(fa,0);mst(ed,0);}
	int idx(char c){return c-'a';}
	void ins(char str[]){
		int u=0,c,h=-1;
		for(int i=0;str[i];++i){
			c=idx(str[i]);
			if(!ch[u][c]){
				ch[u][c]=++sz;
				if(h==-1)h=ch[u][c];
			}
			N[u].pb(ch[u][c]);
			N[ch[u][c]].pb(u);
			u=ch[u][c];
		}
		if(h!=-1){
			N[h].pb(u);
		}
	}
	void build(){
		queue<int> q;
		mst(dis,0x3f);mst(inq,0);
		q.push(0);dis[0]=0;
		while(!q.empty()){
			int u=q.front();q.pop();inq[u]=0;
			for(auto v:N[u]){
				if(dis[v]>dis[u]+1){
					dis[v]=dis[u]+1;
					if(!inq[v]){
						q.push(v);
						inq[v]=1;
					}
				}
			}
		}
	}
	int work(char str[]){
		int len=strlen(str),u=0,c,ans=len;
		for(int i=0;str[i];i++){
			c=idx(str[i]);
			if(ch[u][c])u=ch[u][c];
			else break;
			ans=min(ans,dis[u]+len-i-1);
		}
		return ans;
	}
}T;

char str[maxn];

int main() {
	int n,m;
	T.init();
	scanf("%d%d",&n,&m);
	repb(i,1,n){
		scanf("%s",str);
		T.ins(str);
	}
	T.build();
	repb(i,1,m){
		scanf("%s",str);
		printf("%d\n",T.work(str));
	}
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值