Bless You Autocorrect! 字典树+bfs

Bless You Autocorrect!

 

Typing on phones can be tedious. It is easy to make typing mistakes, which is why most phones come with an autocorrect feature. Autocorrect not only fixes common typos, but also suggests how to finish the word while you type it. Jenny has recently been pondering how she can use this feature to her advantage, so that she can send a particular message with the minimum amount of typing.
The autocorrect feature on Jenny’s phone works like this: the phone has an internal dictionary of words sorted by their frequency in the English language. Whenever a word is being typed,autocorrect suggests the most common word (if any) starting with all the letters typed so far. By pressing tab, the word being typed is completed with the autocorrect suggestion. Autocorrect can only be used after the first character of a word has been typed –it is not possible to press tab before having typed anything. If no dictionary word starts with the letters typed so far, pressing tab has no effect.
Jenny has recently noticed that it is sometimes possible to use autocorrect to her advantage even when it is not suggesting the correct word, by deleting the end of the autocorrected word. For instance, to type the word “autocorrelation”, Jenny starts typing “aut”, which then autocorrects to “autocorrect” (because it is such a common word these days!) when pressing tab. By deleting the last two characters (“ct”) and then typing the six letters “lation”, the whole word can be typed using only 3 (“aut”) + 1 (tab) + 2 (backspace twice) + 6 (“lation”) = 12 keystrokes, 3 fewer than typing “autocorrelation” without using autocorrect.
Given the dictionary on the phone and the words Jenny wants to type, output the minimum number of keystrokes required to type each word. The only keys Jenny can use are the letter keys, tab and backspace.

 

输入

The first line of input contains two positive integers n (1 ≤ n ≤ 105 ), the number of words in the dictionary, and m (1 ≤ m ≤ 10 5 ), the number of words to type. Then follow n lines with one word per line, sorted in decreasing order of how common the word is (the first word is the most common). No word appears twice in the dictionary. Then follow m lines, containing the words to type.
The dictionary and the words to type only use lower case letters ‘ a ’-‘ z ’. The total size  of the input file is at most 1 MB.

 

输出

For each word to type, output a line containing the minimum number of keystrokes required to type the corresponding word.

 

样例输入

5 5
austria
autocorrect
program
programming
computer
autocorrelation
programming
competition
zyx
austria

 

样例输出

12
4
11
3
2
#include<bits/stdc++.h> 
using namespace std;
#define rep(i,s,t) for(int i=s;i<t;++i)
#define repb(i,s,t) for(int i=s;i<=t;i++)
#define mst(a,b) memset(a,b,sizeof(a)) 
#define pb push_back
#define maxn 1100004
const int inf =0x3f3f3f3f; 

vector<int> N[maxn];
int dis[maxn*2],inq[maxn*2];

struct trie{
	int ch[maxn][26],val[maxn],cnt[maxn],fa[maxn],ed[maxn],sz;
	void init(){sz=0;mst(cnt,0);mst(ch,0);mst(val,0);mst(fa,0);mst(ed,0);}
	int idx(char c){return c-'a';}
	void ins(char str[]){
		int u=0,c,h=-1;
		for(int i=0;str[i];++i){
			c=idx(str[i]);
			if(!ch[u][c]){
				ch[u][c]=++sz;
				if(h==-1)h=ch[u][c];
			}
			N[u].pb(ch[u][c]);
			N[ch[u][c]].pb(u);
			u=ch[u][c];
		}
		if(h!=-1){
			N[h].pb(u);
		}
	}
	void build(){
		queue<int> q;
		mst(dis,0x3f);mst(inq,0);
		q.push(0);dis[0]=0;
		while(!q.empty()){
			int u=q.front();q.pop();inq[u]=0;
			for(auto v:N[u]){
				if(dis[v]>dis[u]+1){
					dis[v]=dis[u]+1;
					if(!inq[v]){
						q.push(v);
						inq[v]=1;
					}
				}
			}
		}
	}
	int work(char str[]){
		int len=strlen(str),u=0,c,ans=len;
		for(int i=0;str[i];i++){
			c=idx(str[i]);
			if(ch[u][c])u=ch[u][c];
			else break;
			ans=min(ans,dis[u]+len-i-1);
		}
		return ans;
	}
}T;

char str[maxn];

int main() {
	int n,m;
	T.init();
	scanf("%d%d",&n,&m);
	repb(i,1,n){
		scanf("%s",str);
		T.ins(str);
	}
	T.build();
	repb(i,1,m){
		scanf("%s",str);
		printf("%d\n",T.work(str));
	}
    return 0;
}

 

深度学习是机器学习的一个子领域,它基于人工神经网络的研究,特别是利用多层次的神经网络来进行学习和模式识别。深度学习模型能够学习数据的高层次特征,这些特征对于图像和语音识别、自然语言处理、医学图像分析等应用至关重要。以下是深度学习的一些关键概念和组成部分: 1. **神经网络(Neural Networks)**:深度学习的基础是人工神经网络,它是由多个层组成的网络结构,包括输入层、隐藏层和输出层。每个层由多个神经元组成,神经元之间通过权重连接。 2. **前馈神经网络(Feedforward Neural Networks)**:这是最常见的神经网络类型,信息从输入层流向隐藏层,最终到达输出层。 3. **卷积神经网络(Convolutional Neural Networks, CNNs)**:这种网络特别适合处理具有网格结构的数据,如图像。它们使用卷积层来提取图像的特征。 4. **循环神经网络(Recurrent Neural Networks, RNNs)**:这种网络能够处理序列数据,如时间序列或自然语言,因为它们具有记忆功能,能够捕捉数据中的时间依赖性。 5. **长短期记忆网络(Long Short-Term Memory, LSTM)**:LSTM 是一种特殊的 RNN,它能够学习长期依赖关系,非常适合复杂的序列预测任务。 6. **生成对抗网络(Generative Adversarial Networks, GANs)**:由两个网络组成,一个生成器和一个判别器,它们相互竞争,生成器生成数据,判别器评估数据的真实性。 7. **深度学习框架**:如 TensorFlow、Keras、PyTorch 等,这些框架提供了构建、训练和部署深度学习模型的工具和库。 8. **激活函数(Activation Functions)**:如 ReLU、Sigmoid、Tanh 等,它们在神经网络中用于添加非线性,使得网络能够学习复杂的函数。 9. **损失函数(Loss Functions)**:用于评估模型的预测与真实值之间的差异,常见的损失函数包括均方误差(MSE)、交叉熵(Cross-Entropy)等。 10. **优化算法(Optimization Algorithms)**:如梯度下降(Gradient Descent)、随机梯度下降(SGD)、Adam 等,用于更新网络权重,以最小化损失函数。 11. **正则化(Regularization)**:技术如 Dropout、L1/L2 正则化等,用于防止模型过拟合。 12. **迁移学习(Transfer Learning)**:利用在一个任务上训练好的模型来提高另一个相关任务的性能。 深度学习在许多领域都取得了显著的成就,但它也面临着一些挑战,如对大量数据的依赖、模型的解释性差、计算资源消耗大等。研究人员正在不断探索新的方法来解决这些问题。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值