UVA 11234 - Expressions

Description

Download as PDF
2007/2008 ACM International Collegiate Programming Contest 
University of Ulm Local Contest

Problem E: Expressions

Arithmetic expressions are usually written with the operators in between the two operands (which is called infix notation). For example,(x+y)*(z-w) is an arithmetic expression in infix notation. However, it is easier to write a program to evaluate an expression if the expression is written in postfix notation (also known as reverse polish notation). In postfix notation, an operator is written behind its two operands, which may be expressions themselves. For example, x y + z w - * is a postfix notation of the arithmetic expression given above. Note that in this case parentheses are not required.

To evaluate an expression written in postfix notation, an algorithm operating on a stack can be used. A stack is a data structure which supports two operations:

  1. push: a number is inserted at the top of the stack.
  2. pop: the number from the top of the stack is taken out.

During the evaluation, we process the expression from left to right. If we encounter a number, we push it onto the stack. If we encounter an operator, we pop the first two numbers from the stack, apply the operator on them, and push the result back onto the stack. More specifically, the following pseudocode shows how to handle the case when we encounter an operator O:

a := pop();
b := pop();
push(b O a);

The result of the expression will be left as the only number on the stack.

Now imagine that we use a queue instead of the stack. A queue also has a push and pop operation, but their meaning is different:

  1. push: a number is inserted at the end of the queue.
  2. pop: the number from the front of the queue is taken out of the queue.

Can you rewrite the given expression such that the result of the algorithm using the queue is the same as the result of the original expression evaluated using the algorithm with the stack?

Input Specification

The first line of the input contains a number T (T ≤ 200). The following T lines each contain one expression in postfix notation. Arithmetic operators are represented by uppercase letters, numbers are represented by lowercase letters. You may assume that the length of each expression is less than 10000 characters.

Output Specification

For each given expression, print the expression with the equivalent result when using the algorithm with the queue instead of the stack. To make the solution unique, you are not allowed to assume that the operators are associative or commutative.

Sample Input
2
xyPzwIM
abcABdefgCDEF
Sample Output
wzyxIPM
gfCecbDdAaEBF
规则:遇到数字push进线性表中,遇到操作符,从线性表中pop()出两元素,计算后再push进去。
这个题的意思是让你求一表达示,使用队列按照上面规则操作得到的结果与给定的字符串用栈按上面规则操作得到的结果相同。
刚开始看到这个题一点思路也没有。后来到网上查了下,说是要建树,后来就明白了。
首先利用后辍表达式建好树,然后宽度优先遍历就行了。
language:c++
code:
#include<iostream>
#include<vector>
#include<string>
#include<stack>
#include<queue>
#include<cctype>
using namespace std;

struct node
{
    char data;
    node* left,*right;
    node(char d=0,node*l=0,node*r=0):data(d),left(l),right(r){}
};

node *build(char data,node* left,node* right)
{
    node*father=new node(data,left,right);
    return father;
}

int main()
{
    string s;
    int cas;
    cin>>cas;
    while(cas--)
    {
        cin>>s;
        stack<node*>stck;
        queue<node*>que;
        string ans;
        for(size_t i=0;i!=s.size();i++)
        {
            if(islower(s[i]))
            {
                node* tree=new node(s[i],0,0);
                stck.push(tree);
            }
            else
            {
                node* r=stck.top();stck.pop();
                node* l=stck.top();stck.pop();
                stck.push(build(s[i],l,r));
            }
        }
        que.push(stck.top());
        while(!que.empty())
        {
            node* cur=que.front();que.pop();
            ans+=cur->data;
            if(cur->left)que.push(cur->left);
            if(cur->right)que.push(cur->right);
        }
        for(int i=ans.size()-1;i>-1;i--)
            cout<<ans[i];
        cout<<endl;
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值