[map] Easy Math 四川第七届省赛A

Easy Math

Given nn integers a1,a2,,ana1,a2,…,an, check if the sum of their square root a1+a2++ana1+a2+⋯+an is a integer.

Input

The input consists of multiple tests. For each test:

The first line contains 11 integer nn (1n1051≤n≤105). The second line contains nnintegers a1,a2,,ana1,a2,…,an (0ai1090≤ai≤109).

Output

For each test, write "Yes" if the sum is a integer, or "No" otherwise.

Sample Input

    2
    1 4
    2
    2 3

Sample Output

    Yes
    No

#include <bits/stdc++.h>
using namespace std;
map<long long,bool>m;  //map
int main()
{
    for(int i=0;i<=100000;i++)
        m[i*i]=1;  //标记存在
    int n;while(~scanf("%d",&n))
    {
        bool flag=1;
        while(n--)
        {
            int c;scanf("%d",&c);
            if(!m[c]&&flag)
            {
                printf("No\n");
                flag=0;
            }
        }
        if(!flag) continue;
        printf("Yes\n");
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值