继续畅通工程
Time Limit : 2000/1000ms (Java/Other) Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 17 Accepted Submission(s) : 14
Font: Times New Roman | Verdana | Georgia
Font Size: ← →
Problem Description
省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可)。现得到城镇道路统计表,表中列出了任意两城镇间修建道路的费用,以及该道路是否已经修通的状态。现请你编写程序,计算出全省畅通需要的最低成本。
Input
测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( 1< N < 100 );随后的 N(N-1)/2 行对应村庄间道路的成本及修建状态,每行给4个正整数,分别是两个村庄的编号(从1编号到N),此两村庄间道路的成本,以及修建状态:1表示已建,0表示未建。
当N为0时输入结束。
当N为0时输入结束。
Output
每个测试用例的输出占一行,输出全省畅通需要的最低成本。
Sample Input
3 1 2 1 0 1 3 2 0 2 3 4 0 3 1 2 1 0 1 3 2 0 2 3 4 1 3 1 2 1 0 1 3 2 1 2 3 4 1 0
Sample Output
3 1 0
Author
ZJU
Source
浙大计算机研究生复试上机考试-2008年
#include <bits/stdc++.h>
using namespace std;
const int mn = 110;
const int mm = 110 * 110;
int n, m;
int p[mn];
int par(int a)
{
if (p[a] == a)
return a;
return p[a] = par(p[a]);
}
struct node
{
int x, y, z;
} e[mm];
bool cmp(const node& a, const node& b)
{
return a.z < b.z;
}
int main()
{
while (scanf("%d", &n) && n)
{
for (int i = 1; i <= n; i++)
p[i] = i;
int sz = 0,sum = 0;
int ti = n * (n - 1) / 2;
for (int i = 1 ; i <= ti; i++)
{
int a, b, c, con;
scanf("%d %d %d %d", &a, &b, &c, &con);
if (con == 1)
{
int pa = par(a);
int pb = par(b);
if (pa != pb)
{
p[pa] = pb;
sz++;
}
continue;
}
e[sum].x = a;
e[sum].y = b;
e[sum].z = c;
sum++;
e[sum].x = b;
e[sum].y = a;
e[sum].z = c;
sum++;
}
sort (e, e + sum, cmp);
int ans = 0;
for (int i = 1; i < sum; i++)
{
if (sz == n - 1)
break;
int px = par(e[i].x);
int py = par(e[i].y);
if (px != py)
{
p[px] = py;
sz++;
ans += e[i].z;
}
}
printf("%d\n", ans);
}
return 0;
}