[二进制] Binary Tree HDU5573

Binary Tree

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1743    Accepted Submission(s): 1043
Special Judge

 

Problem Description

The Old Frog King lives on the root of an infinite tree. According to the law, each node should connect to exactly two nodes on the next level, forming a full binary tree.

Since the king is professional in math, he sets a number to each node. Specifically, the root of the tree, where the King lives, is 1. Say froot=1.

And for each node u, labels as fu, the left child is fu×2 and right child is fu×2+1. The king looks at his tree kingdom, and feels satisfied.

Time flies, and the frog king gets sick. According to the old dark magic, there is a way for the king to live for another N years, only if he could collect exactly Nsoul gems.

Initially the king has zero soul gems, and he is now at the root. He will walk down, choosing left or right child to continue. Each time at node x, the number at the node is fx (remember froot=1), he can choose to increase his number of soul gem by fx, or decrease it by fx.

He will walk from the root, visit exactly K nodes (including the root), and do the increasement or decreasement as told. If at last the number is N, then he will succeed.

Noting as the soul gem is some kind of magic, the number of soul gems the king has could be negative.

Given N, K, help the King find a way to collect exactly N soul gems by visiting exactly K nodes.

 

 

Input

First line contains an integer T, which indicates the number of test cases.

Every test case contains two integers N and K, which indicates soul gems the frog king want to collect and number of nodes he can visit.

⋅ 1≤T≤100.

⋅ 1≤N≤109.

⋅ N≤2K≤260.

 

 

Output

For every test case, you should output "Case #x:" first, where x indicates the case number and counts from 1.

Then K lines follows, each line is formated as 'a b', where a is node label of the node the frog visited, and b is either '+' or '-' which means he increases / decreases his number by a.

It's guaranteed that there are at least one solution and if there are more than one solutions, you can output any of them.

 

 

 

Sample Input

 

2

5 3

10 4

 

 

Sample Output

 

Case #1:

1 +

3 -

7 +

Case #2:

1 +

3 +

6 -

12 +

 

 

Source

2015ACM/ICPC亚洲区上海站-重现赛(感谢华东理工)

 

 

#include <bits/stdc++.h>
#define ll long long
using namespace std;

int ch[50];
ll mi[100];
int main()
{
	mi[0] = 1;
	for (int i = 1; i <= 61; i++)
		mi[i] = 2 * mi[i - 1];
	
	int T;
	scanf ("%d", &T);
	for (int cas = 1; cas <= T; cas++)
	{
		printf("Case #%d:\n", cas);
		
		int n, k;
		scanf("%d %d", &n, &k);
		
		/// 1, 2, 4, 8, 16, ... , 2 ^ (n - 1) 求和等于2 ^ n - 1
		/// n <= 2 ^ k -> 只走最左一列
		int len = 0;
		int temp = n;
		if (n % 2 == 0)
			temp -= 1;
		while (temp > 0)
		{
			ch[len++] = (temp & 1);
			temp >>= 1;
		} 
		/// 使 t 为奇数, 将所求转化为二进制,则只在最左子树上操作
		
		/// 将转换后二进制数如 1000100101011
		/// 从右往左(从0到len) 分成 1(000) 形式的段
		/// 每段最后一位 + 其他 - 
		for (int i = 0; i < len - 1; i++)
		{
			if (ch[i + 1] == 1)
				printf("%lld +\n", mi[i]);
			else 
				printf("%lld -\n", mi[i]);
		}
		if (n % 2 == 0) // 最后一叉向右子树 +1
			printf("%lld +\n", mi[len - 1] + 1);
		else 
			printf("%lld +\n", mi[len - 1]);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值