HDU 5573 Binary Tree (二进制,位运算)

原题地址: 传送门 http://acm.hdu.edu.cn/showproblem.php?pid=5573

Binary Tree

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 499    Accepted Submission(s): 287
Special Judge


Problem Description
The Old Frog King lives on the root of an infinite tree. According to the law, each node should connect to exactly two nodes on the next level, forming a full binary tree.

Since the king is professional in math, he sets a number to each node. Specifically, the root of the tree, where the King lives, is 1 . Say froot=1 .

And for each node u , labels as fu , the left child is fu×2 and right child is fu×2+1 . The king looks at his tree kingdom, and feels satisfied.

Time flies, and the frog king gets sick. According to the old dark magic, there is a way for the king to live for another N years, only if he could collect exactly N soul gems.

Initially the king has zero soul gems, and he is now at the root. He will walk down, choosing left or right child to continue. Each time at node x , the number at the node is fx (remember froot=1 ), he can choose to increase his number of soul gem by fx , or decrease it by fx .

He will walk from the root, visit exactly K nodes (including the root), and do the increasement or decreasement as told. If at last the number is N , then he will succeed.

Noting as the soul gem is some kind of magic, the number of soul gems the king has could be negative.

Given N , K , help the King find a way to collect exactly N soul gems by visiting exactly K nodes.
 

Input
First line contains an integer T , which indicates the number of test cases.

Every test case contains two integers N and K , which indicates soul gems the frog king want to collect and number of nodes he can visit.

1T100 .

1N109 .

N2K260 .
 

Output
For every test case, you should output " Case #x:" first, where x indicates the case number and counts from 1 .

Then K lines follows, each line is formated as 'a b', where a is node label of the node the frog visited, and b is either '+' or '-' which means he increases / decreases his number by a .

It's guaranteed that there are at least one solution and if there are more than one solutions, you can output any of them.

 

Sample Input
  
  
2 5 3 10 4
 

Sample Output
  
  
Case #1: 1 + 3 - 7 + Case #2: 1 + 3 + 6 - 12 +
 



题目大意就是,给你一个无限大的满的二叉树,结点的权值为1、2、3……
给你一个N和一个K。
从二叉树的根节点(权值为1)开始,寻找一条有K个节点的路,通过对这些节点权值的加减,得到数N。

比如
5  3

1
2                       3
4         5           6          7
8   9   10  11  12  13  14  15
……
我们可以通过路1->3->7
1-3+7=5
这样来得到5


N <= 2^K
我们可以发现,我们只需要通过最左边的路径,1->2->4->8->……
取其中的前k个结点进行加减,就可以得到 1 ~ 2^k 之内所有的奇数。并且,最后一个结点必然是正的。
8-4-2-1=1
8-4-2+1=3
8-4+2-1=5
8-4+2+1=7
8+4-2-1=9
……
8+4+2+1=15

而如果要表示偶数,只要在奇数的最后一个结点加一,便能得到其偶数。

1 2 4 8 16 ……
让我们想到二进制。
我们可以把这个奇数,当成是两个数相减得到。而且这两个数,对应的二进制数每一个位都不一样。

比如5
5=8-4+2-1
  =(8+2)-(4+1)

其二进制为
     1010-0101=5

而且,很显然,这两个数加起来,等于2^k-1

当n为奇数时
设A-B=n
   A+B=2^k-1
解得
   A=(n+2^k-1)/2

于是如果A的二进制的第i位是1,输出+,否则输出-。

关于二进制和位运算,可以看一下我的另一篇博客,FZU 1892 接水管游戏。
http://blog.csdn.net/lulu11235813/article/details/51207509

下面贴代码:
#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<cstring>
#include<algorithm>

using namespace std;

int main()
{
    int t,cake=1;
    scanf("%d",&t);
    while(t--)
    {
        long long int n,k;
        scanf("%I64d%I64d",&n,&k);
        long long y=n;
        long long x=(1<<k)-1;
        if(n%2==0)
        {
            y=n-1;
        }
        long long int A=(x+y)/2;
        //long long int B=A-y;
        printf("Case #%d:\n",cake++);
        int i;
        for(i=0;i<k-1;i++)
        {
            long long int m;
            m=1<<i;
            if(A&m)
            {
                printf("%d +\n",m);
            }
            else
            {
                printf("%d -\n",m);
            }
        }
        long long int m=1<<i;
        if(n%2==0)
        {
            printf("%I64d +\n",m+1);
        }
        else
        {
            printf("%I64d +\n",m);
        }
    }
    return 0;
}




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值