[状压DP] 每个人排在不同位置有不同贡献 求队伍贡献值一定的方案数 ZOJ3777

1 篇文章 0 订阅

B - Problem Arrangement

 ZOJ - 3777 

The 11th Zhejiang Provincial Collegiate Programming Contest is coming! As a problem setter, Edward is going to arrange the order of the problems. As we know, the arrangement will have a great effect on the result of the contest. For example, it will take more time to finish the first problem if the easiest problem hides in the middle of the problem list.

There are N problems in the contest. Certainly, it's not interesting if the problems are sorted in the order of increasing difficulty. Edward decides to arrange the problems in a different way. After a careful study, he found out that the i-th problem placed in the j-th position will add Pij points of "interesting value" to the contest.

Edward wrote a program which can generate a random permutation of the problems. If the total interesting value of a permutation is larger than or equal to M points, the permutation is acceptable. Edward wants to know the expected times of generation needed to obtain the first acceptable permutation.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains two integers N (1 <= N <= 12) and M (1 <= M <= 500).

The next N lines, each line contains N integers. The j-th integer in the i-th line is Pij (0 <= Pij <= 100).

Output

For each test case, output the expected times in the form of irreducible fraction. An irreducible fraction is a fraction in which the numerator and denominator are positive integers and have no other common divisors than 1. If it is impossible to get an acceptable permutation, output "No solution" instead.

Sample Input

2
3 10
2 4 1
3 2 2
4 5 3
2 6
1 3
2 4

Sample Output

3/1
No solution

 

#include <bits/stdc++.h>
using namespace std;

int dp[5010][510];
int mp[20][20];
int book[5010];
int jie[20];

int main()
{
	jie[0] = 1;
	for(int i = 1; i <= 12; i ++)
		jie[i] = jie[i - 1] * i;

	for(int i = 0; i < (1 << 12); i++)	/// 预处理每个状态有几个1
	{
		int temp = i, ans = 0;
		while(temp)
		{
			if(temp & 1)
				ans ++;
			temp >>= 1;
		}
		book[i] = ans;
	}
	
	int T;
	scanf("%d", &T);
	while(T --)
	{
		int n, m;
		scanf("%d %d", &n, &m);
		for(int i = 1; i <= n; i++)
			for(int j = 0; j < n; j++)
				scanf("%d", &mp[i][j]);
				
		memset(dp, 0, sizeof(dp));
		dp[0][0] = 1;
		
		for(int i = 1; i <= n; i++)		/// 枚举到第 i 个人
		{
			for(int j = 0; j < n; j++)	/// 这个人放在 j 位
			{
				for(int qian = 0; qian < (1 << n); qian++)		/// 前 i - 1 个人所处的位置状态
				{
					if(book[qian] != i - 1 || (qian & (1 << j)) == (1 << j))	/// 要求第 j 位为空
						continue;
					int xian = qian + (1 << j);
					for (int k = 0; k <= 500; k++)		/// 超出上界并入上界无影响
						dp[xian][min(500, k + mp[i][j])] += dp[qian][k];
				}
			}
		}

		int temp = 0;
		for (int i = m; i <= 500; i++)
			temp += dp[(1 << n) - 1][i];
		if (temp == 0)
			printf("No solution\n");
		else
		{
			int G = __gcd(temp, jie[n]);
			printf("%d/%d\n", jie[n] / G, temp / G);
		}
	}
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值