ZOJ - 3777 Problem Arrangement (状压dp)

The 11th Zhejiang Provincial Collegiate Programming Contest is coming! As a problem setter, Edward is going to arrange the order of the problems. As we know, the arrangement will have a great effect on the result of the contest. For example, it will take more time to finish the first problem if the easiest problem hides in the middle of the problem list.

There are N problems in the contest. Certainly, it's not interesting if the problems are sorted in the order of increasing difficulty. Edward decides to arrange the problems in a different way. After a careful study, he found out that the i-th problem placed in the j-th position will add Pij points of "interesting value" to the contest.

Edward wrote a program which can generate a random permutation of the problems. If the total interesting value of a permutation is larger than or equal to M points, the permutation is acceptable. Edward wants to know the expected times of generation needed to obtain the first acceptable permutation.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains two integers N (1 <= N <= 12) and M (1 <= M <= 500).

The next N lines, each line contains N integers. The j-th integer in the i-th line is Pij (0 <= Pij <= 100).


Output

For each test case, output the expected times in the form of irreducible fraction. An irreducible fraction is a fraction in which the numerator and denominator are positive integers and have no other common divisors than 1. If it is impossible to get an acceptable permutation, output "No solution" instead.


Sample Input
2
3 10
2 4 1
3 2 2
4 5 3
2 6
1 3
2 4

Sample Output
3/1
No solution

https://blog.csdn.net/xiangAccepted/article/details/80069093

题意 : 要求你在n*n个数字中找n个数字,这n个数字中的任意两个数不能是同一行或者是同一列。求这n个数字的和大于等于m的概率是多少?(化简之后输出,若不存在输出"No solution")

#include<stdio.h>
#include<string>
#include<string.h>
#include<iostream>
#include<math.h>
#include<queue>
#include<vector>
#include<algorithm>
#include<map>d
#define inf 0x3f3f3f3f
#define mem(a,b) memset(a,b,sizeof a)
#define ll long long
#define maxx 5000005
using namespace std;
int t,n,m;
int dp[1<<13][600];//dp[i][j],i是状态 ,j是值,存的是个数
int a[13][13];//原图
bool vis[1<<13];
vector<int>v[13];//存状态
int main()
{
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;i++) 
            for(int j=1;j<=n;j++)
               scanf("%d",&a[i][j]);
        v[0].clear();
        v[0].push_back(0);
        for(int i=1;i<=n;i++)
        {
            mem(vis,0);
            v[i].clear();
            for(int j=0;j<n;j++)
            {
                int h=1<<j; //代表i想放在第j个,他二进制的状态就是 1<<j
                for(int k=0;k<v[i-1].size();k++)
                {
                    if(!(h&v[i-1][k])&&!vis[h+v[i-1][k]])//如果他的状态和上一行的当前状态不冲突或者 h+v[i-1][k]这个状态没存过
                    {
                        v[i].push_back(h+v[i-1][k]);
                        vis[h+v[i-1][k]]=1;
                    }
                }
            }
        }
        mem(dp,0);
        dp[0][0]=1;
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                int w=1<<(j-1);
                for(int h=0;h<v[i-1].size();h++)
                {
                    if(v[i-1][h]&w) continue;
                    int sum=v[i-1][h]+w;
                    for(int k=0;k<=m;k++)
                    {
                        int q=k+a[i][j];
                        if(q>m) q=m;//如果大于等于m,那么算m就好
                        dp[sum][q]+=dp[v[i-1][h]][k];
                    }
                }
            }
        }
        int ans1=dp[(1<<n)-1][m];
        if(ans1==0)
        {
             printf("No solution\n");
            continue;
        }
        int ans2=1;
        for(int i=1;i<=n;i++)
            ans2*=i;
        int ans=__gcd(ans1,ans2);
        printf("%d/%d\n",ans2/ans,ans1/ans);
    }
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值