[tarjan + lca] 动态加边求桥

这篇博客主要讨论了网络管理员如何通过动态添加链接来消除网络中的桥梁(关键链接)。问题来源于POJ - 3694,初始网络由N台计算机和M条链接组成,管理员计划逐个添加新链接以消除所有桥梁。输入包括多组测试用例,每组包含计算机数量、初始链接数量和计划添加的新链接数量。对于每次添加,输出当前网络中的桥梁数量。该问题涉及图论和网络流知识。
摘要由CSDN通过智能技术生成

D - Network

 POJ - 3694 

A network administrator manages a large network. The network consists of N computers and M links between pairs of computers. Any pair of computers are connected directly or indirectly by successive links, so data can be transformed between any two computers. The administrator finds that some links are vital to the network, because failure of any one of them can cause that data can't be transformed between some computers. He call such a link a bridge. He is planning to add some new links one by one to eliminate all bridges.

You are to help the administrator by reporting the number of bridges in the network after each new link is added.

Input

The input consists of multiple test cases. Each test case starts with a line containing two integers N(1 ≤ N ≤ 100,000) and M(N - 1 ≤ M ≤ 200,000).
Each of the following M lines contains two integers A and B ( 1≤ A ≠ B ≤ N), which indicates a link between computer A and B. Computers are numbered from 1 to N. It is guaranteed that any two computers are connected in the initial network.
The next line contains a single integer Q ( 1 ≤ Q ≤ 1,000), which is the number of new links the administrator plans to add to the network one by one.
The i-th line of the following Q lines contains two integer A and B (1 ≤ A ≠ B ≤ N), which is the i-th added new link connecting computer A and B.

The last test case is followed by a line containing two zeros.

Output

For each test case, print a line containing the test case number( beginning with 1) and Q lines, the i-th of which contains a integer indicating the number of bridges in the network after the first i new links are added. Print a blank line after the output for each test case.

Sample Input

3 2
1 2
2 3
2
1 2
1 3
4 4
1 2
2 1
2 3
1 4
2
1 2
3 4
0 0

Sample Output

Case 1:
1
0

Case 2:
2
0
#include <iostream>
#include <cstdio>
#include <cmath>
#include <stack>
#include <cstring>
#include <map>
#include <queue>
#define ll long long
#define db double
using namespace std;
 
const int mn = 1e5 + 5, mm = 4e5 + 5;
 
int ecnt, to[mm], nx[mm], fr[mn];
void addedge(int u, int v)
{
	to[ecnt] = v;
	nx[ecnt] = fr[u];
	fr[u] = ecnt++;
}
 
/// Tarjan 模板
int kcnt, kuai[mn];
int bridge, idx, low[mn], dfn[mn];
bool insta[mn];
stack<int> sta;
void tarjan(int u, int fa)
{
	low[u] = dfn[u] = ++idx;
	sta.push(u);
	insta[u] = 1;
	for (int i = fr[u]; i != -1; i = nx[i])
	{
		int v = to[i];
		if (v == fa)
			continue;
		if (!dfn[v])
		{
			tarjan(v, u);
			low[u] = min(low[u], low[v]);
 
            /// 求割边
			if (low[v] > dfn[u])
				bridge++;
			/// 
		}
		if (dfn[v] && insta[v])
			low[u] = min(low[u], dfn[v]);
	}
	if (low[u] == dfn[u])
	{
		++kcnt;
		int v;
		do
		{
			v = sta.top();
			kuai[v] = kcnt;
			insta[v] = 0;
			sta.pop();
		}
		while (v != u);
	}
}
///
 
void init()
{
	ecnt = 0, idx = 0;
	memset(fr, -1, sizeof fr);
	memset(low, 0, sizeof low);
	memset(dfn, 0, sizeof dfn);
	memset(insta, 0, sizeof insta);
	while (!sta.empty())
		sta.pop();
	bridge = 0, kcnt = 0;
	memset(kuai, 0, sizeof kuai);
}

/// 去重边
map<int, bool> mp;
bool ishash(int u, int v)
{
	if (mp[u * mn + v] || mp[v * mn + u])
		return 1;
	mp[u * mn + v] = mp[v * mn + u] = 1;
	return 0;
}
///

int ecnt2, to2[mm], nx2[mm], fr2[mn];
void addedge2(int u, int v)
{
	to2[ecnt2] = v;
	nx2[ecnt2] = fr2[u];
	fr2[u] = ecnt2++;
}

int dep[mn], fa[mn], is[mn];
void bfs(int r)
{
	memset(dep, -1, sizeof dep);
	dep[r] = 0;
	fa[r] = -1;
	is[r] = 0;
	queue<int> q;
	q.push(r);
	while (!q.empty())
	{
		int u = q.front();
		q.pop();
		for (int i = fr2[u]; i != -1; i = nx2[i])
		{
			int v = to2[i];
			if (dep[v] != -1)
				continue;
			fa[v] = u;
			dep[v] = dep[u] + 1;
			is[v] = 1;
			q.push(v);
		}
	}
}

int lca(int u, int v)
{
	int ans = 0;
	if (dep[u] > dep[v])
		swap(u, v);
	while (dep[u] < dep[v])
	{
		if (is[v])
			is[v] = 0, ans++;
		v = fa[v];
	}
	while (u != v)
	{
		if (is[u])
			is[u] = 0, ans++;
		if (is[v])
			is[v] = 0, ans++;
		u = fa[u], v = fa[v];
	}
	return ans;
}


int main()
{
	for (int cas = 1; ; cas++)
	{
		init();
		
		int n, m;
		scanf("%d %d", &n, &m);
		if (n == 0 && m == 0)
			break;
		while (m--)
		{
			int u, v;
			scanf("%d %d", &u, &v);
			addedge(u, v);
			addedge(v, u);
		}
		
		tarjan(1, 0);
		
		// 连通块建图
		mp.clear();
		ecnt2 = 0;
		memset(fr2, -1, sizeof fr2);
		for (int i = 1; i <= n; i++)
		{
			for (int j = fr[i]; j != -1; j = nx[j])
			{
				int u = kuai[i], v = kuai[to[j]];
				if (ishash(u, v))
					continue;
				addedge2(u, v);
				addedge2(v, u);
			}
		}
		
		// 连通块图的树处理出 dep[] 和 fa[]
		bfs(1);
		
		printf("Case %d:\n", cas);
		int q;
		scanf("%d", &q);
		while (q--)
		{
			int u, v;
			scanf("%d %d", &u, &v);
			
			int temp = lca(kuai[u], kuai[v]);	// 求两点到lca经过的割边数
			bridge -= temp;
			printf("%d\n", bridge);
		}
	}
	
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值