poj 3246 Balanced Lineup

Balanced Lineup
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 59869 Accepted: 28040
Case Time Limit: 2000MS

Description

For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers,  N and  Q
Lines 2.. N+1: Line  i+1 contains a single integer that is the height of cow  i 
Lines  N+2.. N+ Q+1: Two integers  A and  B (1 ≤  A ≤  B ≤  N), representing the range of cows from  A to  B inclusive.

Output

Lines 1.. Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0

Source


题意:有n头牛每头牛有自己特定的高度,找出对于区间中最高的牛和最低的牛高度之差

用RMQ st算法进行求解

//st算法  rmq

#include <iostream>
#include <cstdio>
#include <cmath>
#include <algorithm>
using namespace std;
const int maxn=50005;
int a[maxn],dp[maxn][30],dp1[maxn][30],vis[maxn];//dp[i][j]表示从第i位开始连续的2^j个数中的最小值
void init(int n)
    {
        for (int i=1;i<=n;i++)
            {
                dp[i][0]=a[i],dp1[i][0]=a[i];
            }
        for (int j=1;(1<<j)<=n;j++)
            for (int i=1;i+(1<<j)-1<=n;i++)
                {
                    dp[i][j]=max(dp[i][j-1],dp[i+(1<<(j-1))][j-1]);
                    dp1[i][j]=min(dp1[i][j-1],dp1[i+(1<<(j-1))][j-1]);
                }
    }
int minrmq(int l,int r){
    int k=log2(r-l+1);
    return min(dp1[l][k],dp1[r-(1<<k)+1][k]);
}
int maxrmq(int l,int r){
    int k=log2(r-l+1);
    return max(dp[l][k],dp[r-(1<<k)+1][k]);
}
int main()
    {
        int n,m;
        int A,B;
        while (scanf("%d%d",&n,&m)!=EOF)
            {
                for (int i=1;i<=n;i++)
                    scanf("%d",&a[i]);
                init(n);
                for (int i=0;i<m;i++)
                    {
                        scanf("%d%d",&A,&B);
                        printf("%d\n",maxrmq(A,B)-minrmq(A,B));
                    }
            }
        return 0;
    }

还有一种线段数的求法,暂时先放一下,下次更新

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值