Buy Tickets

55 篇文章 0 订阅
22 篇文章 0 订阅

Description
Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input
There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i (1 ≤ i ≤ N). For each i, the ranges and meanings of Posi and Vali are as follows:

Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.
There no blank lines between test cases. Proceed to the end of input.

Output
For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input
4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492
Sample Output
77 33 69 51
31492 20523 3890 19243
Hint
The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.

题意是让你插队,给你一个数字n,下面n行,每行两个数,一个是插队的位置,另一个数是数值,问你最后插完队的最后状态。
这个要想到一个点,就是从后往前。
下面是代码:

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
using namespace std;
int s[200001 * 4], tt[200001 * 4];
struct xx
{
    int a,b;
}x[200001]; 
void build(int rt, int L, int R)
{
    int mid = (L + R) / 2;
    if(L == R)
    {
        s[rt] = 1;       //先将各个节点标记成1
        return ;
    }
    build(rt * 2, L, mid);
    build(rt * 2 + 1, mid + 1, R);
    s[rt] = s[rt * 2] + s[rt * 2 + 1];
}
void update(int rt, int L, int R, int begin, int val)
{
    int mid = (L + R) / 2;
    if(L == R)
    {
        s[rt] = 0; //没用到的就标记成0
        tt[L] = val;
        return ;
    }
    if(begin <= s[rt * 2])
        update(rt * 2, L, mid, begin, val); 
    else
        update(rt * 2 + 1, mid + 1, R, begin - s[rt * 2],val); //注意
    s[rt] = s[rt * 2] + s[rt * 2 + 1];
}
int main()
{
    int n;
    while(~scanf("%d", &n))
    {
        for(int i = 0; i < n; i++)
            scanf("%d %d", &x[i].a, &x[i].b);
        build(1, 1, n); 
        for(int i = n - 1; i >= 0; i--) //从后往前开始
        {
            update(1, 1, n, x[i].a + 1, x[i].b);  //位置从1开始
        }
        for(int i = 1; i <= n; i++)
            printf("%d ", tt[i]);
        puts("");
    }
    return 0;
}

这道题还是不算太明白,希望大神可以帮忙解决一下。

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值