【poj2828】Buy Tickets (segment tree+贪心)

F - Buy Tickets
Time Limit:4000MS Memory Limit:65536KB 64bit IO Format:%I64d & %I64u
Submit

Status
Description
Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input
There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i (1 ≤ i ≤ N). For each i, the ranges and meanings of Posi and Vali are as follows:

Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.
There no blank lines between test cases. Proceed to the end of input.

Output
For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input
4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492
Sample Output
77 33 69 51
31492 20523 3890 19243
Hint
The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.

题意:顺序插队,输出队列。
思路:
1.倒序判断; (无后效性)
2.线段树实现sequence 的空空间;

#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<map>
#define lson (id*2)
#define rson (id*2+1)
using namespace std;
struct node{
    int x,y;
} aa[300000];
int tree[800005];
int n;
map<int,int> ans;
void push_up(int id)
{
    tree[id]=tree[lson]+tree[rson];
}
void build(int id,int l,int r)
{
    if(l==r)
    {
        tree[id]=1;
        return ;
    }
    int mid=(l+r)>>1;
    build(lson,l,mid);
    build(rson,mid+1,r);
    push_up(id);
}
void add(int id,int l,int r,int pos,int V)
{
    if(l==r)
    {
        ans[l]=V;
        tree[id]--;
        return;
    }
    int mid=(l+r)>>1;
    if(tree[lson]<pos) add(rson,mid+1,r,pos-tree[lson],V);  //倒着走能往前站往前站 
    else  add(lson,l,mid,pos,V);
    push_up(id);
}
int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        build(1,1,n);
        for(int i=1;i<=n;i++)   scanf("%d%d",&aa[i].x,&aa[i].y);

        for(int i=n;i>=1;i--)
        {
            aa[i].x++;
            add(1,1,n,aa[i].x,aa[i].y);
        }
        for(int i=1;i<=n;i++)
        printf("%d ",ans[i]);
        printf("\n");
    }
}

再插个逆序对贪心

和排队似的倒序插入
ZYB’s Premutation
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 207 Accepted Submission(s): 93

Problem Description
ZYB has a premutation P,but he only remeber the reverse log of each prefix of the premutation,now he ask you to
restore the premutation.

Pair (i,j)(i

#include<iostream>
#include<stdio.h>
#define lson (id*2)
#define rson (id*2+1)
using namespace std;
int T;
int n;
struct nod{
    int val;
}tree[50000*8];
int a[50005];
int ans[50005];
void push_up(int id)
{
    tree[id].val=tree[lson].val+tree[rson].val;
}
void build(int id,int l,int r)
{
    if(l==r)
    {
        tree[id].val=1;
        return ;
    }
    int mid=(l+r)>>1;
    build(lson,l,mid);
    build(rson,mid+1,r);
    push_up(id);
}
void add(int id,int l,int r,int pos,int V)
{
    if(l==r)
    {
        ans[V]=l;
        tree[id].val=0;
        return ;
    }
    int mid=(l+r)>>1;
    if(pos>tree[rson].val)
    {
        add(lson,l,mid,pos-tree[rson].val,V);//能往大求往大求!!!
    }
    else
    {
        add(rson,mid+1,r,pos,V);
    }
    push_up(id);
}
int main()
{
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        int bb,cc=0;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&bb);
            a[i]=bb-cc;
            cc=bb;
        }
        build(1,1,n);
        for(int i=n;i>=1;i--)
        {
            add(1,1,n,a[i]+1,i);
        }
        for(int i=1;i<=n;i++)
        {
            if(i!=1)
            {

                printf(" ");
            }
            printf("%d",ans[i]);
        }

        printf("\n");
    }
}
  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值