图的dfs+string的输入只能用cin-A1034 Head of a Gang (30分)

1034 Head of a Gang (30分)

One way that the police finds the head of a gang is to check people's phone calls. If there is a phone call between A and B, we say that A and B is related. The weight of a relation is defined to be the total time length of all the phone calls made between the two persons. A "Gang" is a cluster of more than 2 persons who are related to each other with total relation weight being greater than a given threshold K. In each gang, the one with maximum total weight is the head. Now given a list of phone calls, you are supposed to find the gangs and the heads.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers N and K (both less than or equal to 1000), the number of phone calls and the weight threthold, respectively. Then N lines follow, each in the following format:

Name1 Name2 Time

where Name1 and Name2 are the names of people at the two ends of the call, and Time is the length of the call. A name is a string of three capital letters chosen from A-Z. A time length is a positive integer which is no more than 1000 minutes.

Output Specification:

For each test case, first print in a line the total number of gangs. Then for each gang, print in a line the name of the head and the total number of the members. It is guaranteed that the head is unique for each gang. The output must be sorted according to the alphabetical order of the names of the heads.

Sample Input 1:

8 59
AAA BBB 10
BBB AAA 20
AAA CCC 40
DDD EEE 5
EEE DDD 70
FFF GGG 30
GGG HHH 20
HHH FFF 10

Sample Output 1:

2
AAA 3
GGG 3

Sample Input 2:

8 70
AAA BBB 10
BBB AAA 20
AAA CCC 40
DDD EEE 5
EEE DDD 70
FFF GGG 30
GGG HHH 20
HHH FFF 10

Sample Output 2:

0

 AC代码(算法笔记):

#include <iostream>
#include<cstdio>
#include<algorithm>
#include<string.h>
#include<string>
#include<stack>
#include<cmath>
#include<map>
#include<queue>
using namespace std;
#pragma warning(disable:4996)
const int maxn = 2010;

int n, k, totalpeople=0;
int g[maxn][maxn] = { 0 };//边的权值
int weight[maxn] = { 0 };//点的权值
bool vis[maxn] = { false };
map<string, int> s_to_int;//名字到编号
map<int, string> i_to_string;//编号到名字
map<string, int> ans;//犯罪团伙的头目和人数

int to_id(string s) {//将名字转换成int型
	if (s_to_int.find(s) != s_to_int.end())
		return s_to_int[s];
	else {
		s_to_int[s] = totalpeople;//给这个新名字分配一个编号
		i_to_string[totalpeople] = s;//记录这个编号对应的名字
		return totalpeople++;
	}
}

void dfs(int nownum,int &head,int &totalmember,int &totalvalue) {
	totalmember++;
	vis[nownum] = true;
	if (weight[nownum] > weight[head])//当前结点权值大于头结点权值
		head = nownum;
	for (int i = 0; i < totalpeople; i++) {
		if (g[nownum][i] > 0) {//当前节点到i结点可达
			totalvalue += g[nownum][i];//更新团伙总权值
			g[nownum][i] = g[i][nownum] = 0;//删边防止回头
			if (!vis[i])
				dfs(i, head, totalmember, totalvalue);
		}
	}
}

void dfstrave() {
	for (int i = 0; i < totalpeople; i++) {
		if (!vis[i]) {
			int head = i, totalmember = 0, totalvalue = 0;
			dfs(i, head, totalmember, totalvalue);
			if (totalmember > 2 && totalvalue > k)//满足成为团伙的条件
				ans[i_to_string[head]] = totalmember;//将键值对<头目,团伙人数>送入字典ans
		}
	}
}
int main() {
	scanf("%d %d", &n, &k);
	int w;
	string str1, str2;
	for (int i = 0; i < n; i++) {
		cin >> str1 >> str2 >> w;
		int id1 = to_id(str1), id2 = to_id(str2);
		g[id1][id2] += w; g[id2][id1] += w;
		weight[id1] += w; weight[id2] += w;
	}
	dfstrave();
	printf("%d\n", ans.size());
	for (map<string, int> ::iterator it = ans.begin(); it != ans.end(); it++)
		printf("%s %d\n", it->first.c_str(), it->second);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值