AP-Week1 Factstone Benchmark

题目链接:ZOJ

 

Factstone Benchmark

Time Limit: 5000 msMemory Limit: 32768 KB

Amtel has announced that it will release a 128-bit computer chip by 2010, a 256-bit computer by 2020, and so on, continuing its strategy of doubling the word-size every ten years. (Amtel released a 64-bit computer in 2000, a 32-bit computer in 1990, a 16-bit computer in 1980, an 8-bit computer in 1970, and a 4-bit computer, its first, in 1960.)

Amtel will use a new benchmark - the Factstone - to advertise the vastly improved capacity of its new chips. The Factstone rating is defined to be the largest integer n such that n! can be represented as an unsigned integer in a computer word.

Given a year 1960 ≤ y ≤ 2160, what will be the Factstone rating of Amtel's most recently released chip?

Input

There are several test cases. For each test case, there is one line of input containing y. A line containing 0 follows the last test case.

Output

For each test case, output a line giving the Factstone rating.

Sample Input

1960
1981
0

Sample Output

3
8
//Algorithm Practice Week1
//2021-10-3 16:15-16:50
#include <cstdio>
#include <cmath>
using namespace std;
int cal_factstone(int y){
    int exp = 2 + (y - 1960) / 10, res;
    int goal = pow(2, exp);
    double sum = 0.0;
    //printf("exp:%d, goal:%d\n", exp, goal);
    for(int i=1; sum < goal; i++){
        sum += log(i)/log(2);
        if(sum > goal)
            break;
        res = i;
        //printf("i:%d sum:%f\n ", i, sum);
    }
    return res;
}
int main(){
    int y;
    while(scanf("%d", &y)&&y){
        printf("%d\n",cal_factstone(y));
    }
    return 0;
}

 直接算n!是非常难办的,利用Log(n!)=log1 + log2 + ... + log(n) < 2^(2+(y-1960)) 会好很多。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值