HDU 3336 Count the string(kmp + dp)

34 篇文章 0 订阅
15 篇文章 0 订阅

Count the string

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9715 Accepted Submission(s): 4543

Problem Description
It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:
s: “abab”
The prefixes are: “a”, “ab”, “aba”, “abab”
For each prefix, we can count the times it matches in s. So we can see that prefix “a” matches twice, “ab” matches twice too, “aba” matches once, and “abab” matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For “abab”, it is 2 + 2 + 1 + 1 = 6.
The answer may be very large, so output the answer mod 10007.

Input
The first line is a single integer T, indicating the number of test cases.
For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.

Output
For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.

Sample Input
1
4
abab

Sample Output
6

Author
foreverlin@HNU

Source
HDOJ Monthly Contest – 2010.03.06
传送门:点这里

假设两串字符完全相等,next[j]=i,代表s[1…i]==sum[j-i+1….j],这一段其实就是前缀

i~j之间已经不可能有以j结尾的子串是前缀了,不然next【j】就不是 i 了

设dp【i】:以string[i]结尾的子串总共含前缀的数量

所以dp[j]=dp[i]+1,即以i结尾的子串中含前缀的数量加上前j个字符这一前缀

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;
const int maxn = 2e5 + 10;
const int MOD = 10007;

void get_next(char *t,int *next)//next数组模板
{
   int i=0;//Prefix 前缀
   int j=1;//Postfix 后缀
   next[0] = 0;//自定义的,0和1都从0开始匹配
   next[1] = 0;
   while(t[j] != '\0')
   {
       if(t[i] == t[j])//若前后字符匹配,则向前推进
       {
           i++;
           j++;
           next[j] = i;

       }
       else
       {
           i = next[i];///前后字符不匹配,则回溯。注意,此时是i和j不匹配,因此,根据next数组定义,要回溯到next[i]的值
       }
       if(0 == i)//当回溯到首字符时,单独进行处理
       {
           if(t[i] == t[j])
           {
               next[++j] = ++i;
           }
           else next[++j] = i;
       }
   }
}

int main()
{
    int T;
    cin>>T;
    while(T--)
    {
        int n;
        cin>>n;
        char s[maxn];
        cin>>s;
        int next[maxn];
        get_next(s,next);
        int d[maxn];
        memset(d,1,sizeof(d));
        d[0]=0;
        int sum=0;
        for(int i=1;i<=n;i++)
        {
            d[i]=d[next[i]]+1;
            sum += d[i]%10007;
        }
        cout<<sum%10007<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Usher_Ou

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值