Problem D: 整型数组运算符重载

Problem D: 整型数组运算符重载

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 963   Solved: 604
[ Submit][ Status][ Web Board]

Description

定义Array类:

1.拥有数据成员int length和int *mems,分别是数组中元素的个数和元素列表。

2. 无参构造函数,将mems设置为NULL,length为0。

3. 重载==运算符,用于判断两个Array对象是否相等。相等包括两种情况:(1)两个对象是同一个对象,即它们拥有相同的地址(记住: this指针指向当前对象,是当前对象的地址);(2)两个对象的length相同,且mems中对应元素的值相同。其他情况均为不相等。

4. 利用友元函数重载<<和>>运算符。输入、输出格式见下。

Input

输入分多行。

第一行是一个正整数M,表示有M个数组。

每个数组是一行,其中第一个非负整数N表示该数组的元素个数,之后有N个整数。

Output

输出有M行。

第一行输出即为第一个数组。

自第二行开始,首先输出对应的数组元素(两两之间用空格隔开,首尾不能有空格),如果数组为空,则不输出元素。之后根据这个数组与上个数组是否相同,输出“unequal to above.”(不相等)和“equal to above”(相等)。

Sample Input

53 1 2 33 1 2 307 1 2 3 4 5 6 77 1 2 3 4 5 6 8

Sample Output

1 2 31 2 3 equal to above. unequal to above.1 2 3 4 5 6 7 unequal to above.1 2 3 4 5 6 8 unequal to above.

HINT

Append Code

#include<iostream>
#include<cstdio>
using namespace std;
class Array
{
private:
    int length;
    int *mems;
public:
    Array():length(0),mems(NULL){}

    bool operator == (Array &a)
    {
        int i;
        for(i=0;i<length;i++)
        {
            if(mems[i] != a.mems[i])
                break;
        }
        if(this == &a)
            return true;
        else if(a.length == length && length == i)
            return true;
        else return false;
    }
    friend ostream& operator << (ostream &os,Array &a)
    {
        for(int i=0;i<a.length;i++)
        {
            if(i != a.length-1)
                os<<a.mems[i]<<" ";
            else os<<a.mems[i];
        }
        return os;
    }
    friend istream& operator >> (istream &is,Array &a)
    {
        is>>a.length;
        a.mems = new int[a.length];
        for(int i=0;i<a.length;i++)
        {
            is>>a.mems[i];
        }
        return is;
    }
    ~Array(){if(mems != NULL) delete []mems;}
};

int main()
{
    int cases;
    cin>>cases;
    Array arraies[cases];
    for (int i = 0; i < cases; i++)
    {
        cin>>arraies[i];
    }
    cout<<arraies[0]<<endl;
    for (int i = 1; i < cases; i++)
    {
        if (arraies[i] == arraies[i - 1])
        {
            cout<<arraies[i]<<" "<<"equal to above."<<endl;
        }
        else
        {
            cout<<arraies[i]<<" "<<"unequal to above."<<endl;
        }
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Usher_Ou

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值