POJ 2342 Anniversary party(树状DP)

Anniversary party
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8350 Accepted: 4791
Description

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests’ conviviality ratings.
Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go N – 1 lines that describe a supervisor relation tree. Each line of the tree specification has the form:
L K
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line
0 0
Output

Output should contain the maximal sum of guests’ ratings.
Sample Input

7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0
Sample Output

5

题意:一个公司的一些人要去参加一个party,每个人有一个愉悦值,而如果某个人和他的直接上司不能同时在场,给出n个人,每个人的愉悦值以及他们的上司所属关系,问你让那些人去可以让总的愉悦值最大,并求出这个值。

题解:树状DP可以很容易的考虑到每个人都有两种选择,也就是
来或者不来。那么接下来的部分就容易很多了,我们可以很容易的得到状态表示,dp[i][0]表示第i 个人不来;dp[i][[1] 表示第i 个人来。
在状态的转移方面,可以得到,如果第 个人不来的话,那么他的所有子节点就都
有来或不来两种状态,也就是 dp[i][0]=max(dp[j][0],dp[j][1]);同时如果第 i个人来的话,那么他的所有子节点都只能不来,也就是是dp[i][1]=max(dp[j][0])

代码:

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <vector>

using namespace std;
const int maxn = 10000;
int dp[maxn][2];
vector<int> f[maxn];
int v[maxn];
int tree_dp(int x, int s, int fa)
{
    if (dp[x][s] != -1)
    {
        return dp[x][s];
    }
    dp[x][s] = 0;
    if (s)
    {
        dp[x][s] = v[x];
        for (int i = 0;i < f[x].size();i++)
        {
            if (f[x][i] != fa)
            {
                dp[x][s] += tree_dp(f[x][i], 0, x);//上司来,下属不来
            }
        }
    }
    else//上司不来,下属来、不来
    {
        for (int i = 0;i < f[x].size();i++)
        {
            if (f[x][i] != fa)
            {
                dp[x][s] += max(tree_dp(f[x][i], 0, x), tree_dp(f[x][i], 1, x));
            }
        }
    }
    return dp[x][s];
}
int main()
{
    int n;
    while (cin >> n)
    {
        memset(dp, -1, sizeof(dp));
        for (int i = 1;i <= n;i++)
        {
            f[i].clear();
            cin >> v[i];
        }
        int x, y;
        while (cin >> x >> y&&x || y)
        {
            f[x].push_back(y);
            f[y].push_back(x);
        }
        cout << max(tree_dp(1, 0, -1), tree_dp(1, 1, -1))<<endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Usher_Ou

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值