POJ-3278-Catch That Cow[基础BFS]

Catch That Cow
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 81563 Accepted: 25654

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers:  N and  K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

题意:约翰要追逃跑的奶牛。给出约翰的位置n和奶牛的位置k,约翰每分钟可向前移动以一个单位的距离,或者向后移动一个单位的距离,或者移动到本位置2倍距离的地方。而奶牛待在原地不动。问约翰至少需要移动几分钟抓住奶牛?


思路:bfs即可,这种类型题目在CS专业考研机试和IT公司笔试中出现过。


/*
 * @source: POJ-3278
 * @result: Accepted/4692K/1735MS/Java/1028B
 * @author: vcodes
 * @time: 2017-01-08 18:38:05   
 */
import java.util.Scanner;
import java.util.Deque;
import java.util.ArrayDeque;
import java.util.Arrays;

class Node {
	int pos;
	int step;

	Node() {
	}

	Node(int pos, int step) {
		this.pos = pos;
		this.step = step;
	}
}

public class Main {
	Scanner in = new Scanner(System.in);
	static final int MAXN = 100001;
	int n, k;
	int[][] d = { { 1, -1 }, { 1, 1 }, { 2, 0 } };
	boolean[] vis = new boolean[MAXN];

	Main() {
		while (in.hasNext()) {
			Arrays.fill(vis, false);
			n = in.nextInt();
			k = in.nextInt();
			Deque<Node> que = new ArrayDeque<Node>();
			que.offer(new Node(n, 0));
			vis[n] = true;
			while (!que.isEmpty()) {
				Node now = que.poll();
				if (now.pos == k) {
					System.out.println(now.step);
					break;
				}
				for (int i = 0; i < 3; ++i) {
					int netX = now.pos * d[i][0] + d[i][1];
					if (0 <= netX && netX < MAXN && !vis[netX]) {
						vis[netX] = true;
						que.offer(new Node(netX, now.step + 1));
					}
				}
			}
		}
	}
	public static void main(String[] args) {
		new Main();
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值