HDOJ-1016-Prime Ring Problem(素数环)【DFS】

Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.
Note: the number of first circle should always be 1.

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

Sample Input
    
    
6 8
 

Sample Output
    
    
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
/* Function Description:   HDOJ 1016
   Environment:        DEV C++ 5.6.3.1  
   Technique:          ALGORITHM OF DFS
   Version:  			WATER
   Author:                 valar morghulis  
   Date:                   20150806  
   Notes: 关于这道DFS经典题目,需要注意的是
   1.ONLY存在偶数情况、
   2.输出的格式问题,一不留神就PE 
思路为:筛选出N以内的ALL PRIME,然后从1开始,深搜,此题不用剪枝,很好AC 
*/


#include<cstdio>
#include<cmath>
int a[22];
int use[22];
int n;
int  isprime(int num)//chuangjian yi ge function choice all the prime 
{
    int i;
    for(i=2;i<=sqrt(num+0.0);i++)
    {
        if(num%i==0)
            return 0;
    }
    return 1;//dao ci wei zhi sign wei 1 de wei prime else bushi prime
}
void dfs(int num)
{
    int i;
    if(n==num&&isprime(a[0]+a[n-1]))//ci chu judge wheather first && last number de he wei prime
    {
        for(i=0;i<n;i++)
        {    
       
			if(i==n-1)
			{
				printf("%d\n",a[i]);//form  is very important !!  BE CAREFUL!!
			}
			else
			{
				printf("%d ",a[i]);
			}
 		//	printf(i==n-1?"%d\n":"%d ",a[i]);/THIS IS ANOTHER PRINT WAY ,YOU CAN CHOICE IT !
        }
       // printf("\n");
    }
    else
    {
        for(i=2;i<=n;i++)
        {
            if(!use[i]&&isprime(i+a[num-1]))
            {
                a[num]=i;
                use[i]=1;
                dfs(num+1);//dfs next number 
                use[i]=0;// don't forget huisu huan yuan it 
            }
        }
    }
}

int main()
{
    int cnt = 1; 
     while(~scanf("%d",&n))
    {    
        int i;
        for(i=0;i<n;i++)
        use[i]=0;
        a[0]=1;
        printf("Case %d:\n",cnt++);
        dfs(1);
      //  puts("  ");
      printf("\n");
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值