PAT-甲级-1007 Maximum Subsequence Sum (25 分)

60 篇文章 0 订阅
20 篇文章 0 订阅

Given a sequence of K integers { N​1​​, N​2​​, ..., N​K​​ }. A continuous subsequence is defined to be { N​i​​, N​i+1​​, ..., N​j​​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

题目大意:截取连续数列中和最大的连续子数列,分别输出最大和、首位数和末位数;如果最大和为负,输出0、num[0]、num[n-1];如果有多个最大值,则要求连续子数列的首位数和末尾数下标最小。
解题思路:

  • 记录每个下标之前的总和,如果小于0,则将连续子数列和置零;当出现和最大时,保存首尾下标。
     
    #include <iostream>
    #include <vector>
    using namespace std;
    
    #define rep(i,j,k) for(int i=j;i<k;i++)
    
    int main(){
        int n;
        cin>>n;
        int temp=0,max=-1,start=0,end=n-1,mid=0;
        vector<int> num(n);
        rep(i,0,n){
            cin>>num[i];
            temp += num[i];
            if(temp<0){
                temp = 0;
                mid = i+1;
            }
            else if(temp > max){
                max = temp;
                start = mid;
                end = i;
            }
        }
        if(max<0)    max = 0;
        printf("%d %d %d",max,num[start],num[end]);
        return 0;
    }
    

     

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值