PAT-甲级-1155 Heap Paths (30 分)

60 篇文章 0 订阅
该博客主要讨论计算机科学中的堆数据结构,特别是二叉堆。内容涉及如何检查一棵给定的完全二叉树的每个路径是否满足最大堆或最小堆的条件。博客提供了输入和输出规范,并展示了一些样例输入和输出。博主提出了一个问题,即如何判断给定的完全二叉树是否是最大堆、最小堆或非堆,并给出了解题思路。
摘要由CSDN通过智能技术生成

1155 Heap Paths (30 分)

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

One thing for sure is that all the keys along any path from the root to a leaf in a max/min heap must be in non-increasing/non-decreasing order.

Your job is to check every path in a given complete binary tree, in order to tell if it is a heap or not.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (1<N≤1,000), the number of keys in the tree. Then the next line contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, first print all the paths from the root to the leaves. Each path occupies a line, with all the numbers separated by a space, and no extra space at the beginning or the end of the line. The paths must be printed in the following order: for each node in the tree, all the paths in its right subtree must be printed before those in its left subtree.

Finally print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all.

Sample Input 1:

8
98 72 86 60 65 12 23 50

Sample Output 1:

98 86 23
98 86 12
98 72 65
98 72 60 50
Max Heap

Sample Input 2:

8
8 38 25 58 52 82 70 60

Sample Output 2:

8 25 70
8 25 82
8 38 52
8 38 58 60
Min Heap

Sample Input 3:

8
10 28 15 12 34 9 8 56

Sample Output 3:

10 15 8
10 15 9
10 28 34
10 28 12 56
Not Heap

题目大意:给定一棵完全二叉树,输出从根到叶子节点的路径,并判断是否为最大堆Max Heap、最小堆Min Heap,或者Not Heap;

解题思路:

  • dfs输出根路径;
  • 判断是否为堆
#include <iostream>
#include <vector>
using namespace std;
#define rep(i,j,k)    for(int i=j;i<k;i++)
int v[1000],n,isMin=1,isMax=1;
vector<int> path;
void dfs(int index){
    if(index > n)    return;
    path.push_back(v[index]);
    if(2 * index > n){
        int len = path.size();
        rep(i,0,len)
        printf("%d%s",path[i],i!=len-1?" ":"\n");
    }
    dfs(2*index +1);
    dfs(2*index);
    path.pop_back();
}
int main(){
    std::ios::sync_with_stdio(false);
    cin>>n;
    rep(i,1,n+1)    cin>>v[i];
    dfs(1);
    rep(i,2,n+1){
        if(v[i/2] > v[i]) isMin = 0;
        if(v[i/2] < v[i]) isMax = 0;
    }
    if(isMax==1 || isMin==1)
        printf("%s Heap",isMax==1?"Max":"Min");
    else printf("Not Heap");
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值