PAT A1090. Highest Price in Supply Chain (25) [树的遍历]

A supply chain is a network of retailers(零售商) , distributors(经销商) , and suppliers(供应商) –
everyone involved in moving a product from supplier to customer.
Starting from one root supplier, everyone on the chain buys products from one’s supplier in a price P and
sell or distribute them in a price that is r% higher than P. It is assumed that each member in the supply
chain has exactly one supplier except the root supplier, and there is no supply cycle.
Now given a supply chain, you are supposed to tell the highest price we can expect from some retailers.
Input Specification:
Each input file contains one test case. For each case, The first line contains three positive numbers: N
(<=105), the total number of the members in the supply chain (and hence they are numbered from 0 to N-
1); P, the price given by the root supplier; and r, the percentage rate of price increment for each
distributor or retailer. Then the next line contains N numbers, each number Si is the index of the supplier
for the i-th member. Sroot for the root supplier is defined to be -1. All the numbers in a line are separated
by a space.
Output Specification:
For each test case, print in one line the highest price we can expect from some retailers, accurate up to 2
decimal places, and the number of retailers that sell at the highest price. There must be one space
between the two numbers. It is guaranteed that the price will not exceed 1010.
Sample Input:
9 1.80 1.00
1 5 4 4 -1 4 5 3 6
Sample Output:
1.85 2
题⽬⼤意:给⼀棵树,在树根处货物的价格为p,然后每往下⾛⼀层,价格增加r%,求所有叶⼦结点
的最⾼价格,以及这个价格的叶⼦结点个数。
分析:⽤⼆维数组v[i][j]存储,对于每⼀个结点i,它的孩⼦结点的下标push_back存储在v[i]中。⽤深度
优先搜索dfs,保存当前结点的下标index以及当前结点所在层数,当 当前结点的孩⼦结点个数为0的时
候说明是叶⼦结点,更新maxdepth和maxnum的值,最后输出~
注意:如果采⽤保存某个结点的⽗结点的下标的形式,然后⼀直遍历到根结点的深度/⼴度优先,会出
现三个超时。因为从叶⼦结点往上遍历将会把所有路径都⾛⼀遍,很多都是重复⾛的路径,会超时,
没有从根结点往下遍历的⽅式快
记得r是百分⽐,要除以100之后再计算复利

#include <iostream>
#include <cmath>
#include <vector>
using namespace std;
int n, maxdepth = 0, maxnum = 0, temp, root;    //maxdepth价格最高的深度、maxnum有几个最贵 
vector<int> v[100010];
void dfs(int index, int depth) {
	if(v[index].size() == 0) {
	if(maxdepth == depth)
		maxnum++;
	if(maxdepth < depth) {
		maxdepth = depth;
		maxnum = 1;
	}
	return ;
	}
for(int i = 0; i < v[index].size(); i++)
	dfs(v[index][i], depth + 1);
}
int main() {
	double p, r;
	scanf("%d %lf %lf", &n, &p, &r);
	for(int i = 0; i < n; i++) {
		scanf("%d", &temp);
		if(temp == -1)
			root = i;
		else
			v[temp].push_back(i);
	}
	dfs(root, 0);
	printf("%.2f %d", p * pow(1 + r/100, maxdepth), maxnum);
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值